Calibration

Post Reply
FaVo
Posts: 13
Joined: Thu Oct 02, 2014 9:01 am

Calibration

Post by FaVo » Wed Oct 22, 2014 6:35 am

Hi all,

I have done the assembly of my Shapeoko 2 custom build. Now it comes to calibration and trimming. My first test looks like this:

Image

As you can see the beginning and endig of each line is shifted. What can cause this behavior?

Thanks!

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Calibration

Post by cvoinescu » Wed Oct 22, 2014 11:49 am

Anything being loose can cause that. Even the fact that you use a ballpoint pen and the lead can move inside the pen case. But it could be the pen not attached firmly to the Z carriage, lose V-wheels, a floppy belt, the set screw for a belt pulley not being tight, and a number of other things.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

corim123
Posts: 7
Joined: Sat Aug 16, 2014 8:07 am

Re: Calibration

Post by corim123 » Thu Dec 04, 2014 4:54 am

To me the fact that the error happens in roughly the same portion of the plane each time suggests it is something to do with a loose portion of the x or y-axis. It just seems to be a non-random error from one type of motion in particular.

WillAdams
Posts: 8606
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Calibration

Post by WillAdams » Thu Dec 04, 2014 11:30 am

Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

dougal
Posts: 31
Joined: Mon Apr 14, 2014 10:15 pm

Re: Calibration

Post by dougal » Thu Dec 04, 2014 12:22 pm

The misalignment is always at the start and end of a line. On the h i l and other i these happen to line up vertically. So first thing to check is that your pulleys aren't slipping. Might need a flat made on the stepper shaft.

Gadgetman!
Posts: 1061
Joined: Sun Aug 25, 2013 12:44 pm
Location: Norway
Contact:

Re: Calibration

Post by Gadgetman! » Thu Dec 04, 2014 1:18 pm

How much is it slipping?

This is TinyG, right?

What is the $mt variable set to?
Weird guy...
Shapeoko 2014F: 1000mm X/Y, 300W Quiet Cut spindle, Arduino Uno/G-shield and GRBL 0.9i
15x30 drag chains, custom spindle mount, 9mm belts, 8mm endplates, 6mm motor plates.

oniontalker
Posts: 22
Joined: Wed Aug 27, 2014 3:24 pm

Re: Calibration

Post by oniontalker » Sat Dec 06, 2014 1:41 am

Z0 or "depth of cut" might be a little to Z-. The pen might be drifting and when it lifts, it mostly goes back to a stable position.
I'd try with a sharpie or some sort of felt tipped instrument and reduce the, "depth of cut", to rule that out.

FaVo
Posts: 13
Joined: Thu Oct 02, 2014 9:01 am

Re: Calibration

Post by FaVo » Tue Dec 16, 2014 2:11 pm

Sorry for my late answer.... the most alignment problem wasn't a real problem but flexing of the pen... like many many other already had.
Even if the pen and the mounting of the pen looks stiff... IT ISN'T.

Adding an endmill and cutting some test patterns into wood looks way better than drawing with a pen.

That is my experience (and as I can read in the forum, many other did make this experience as well).

Post Reply