Help sorting a "Hello World" problem

Post Reply
tylorch
Posts: 3
Joined: Fri Dec 26, 2014 7:31 pm
Location: Montreal, QC, Canada

Help sorting a "Hello World" problem

Post by tylorch » Fri Dec 26, 2014 9:11 pm

Hi all,
I recently picked up the Shapeoko 2 full kit (Black Friday sale).
I've spent a weekend building it before Christmas and have spent the last week troubleshooting it.

I'm getting a little cross-eyed trying to sort this out and would appreciate some suggestions / input on my next steps.

I wired it per the assembly instructions (opted for wiring option 2).
Turns out with these steppers, I had to reverse all the black/green wire pairs or it ran "in reverse" (in manual control with Universal g-code sender, + = - and - = +).

Once I got the X and Y sorted in terms of + = + and - = -, I turned my attention to the Z-axis.
It occasionally makes loud noises (grinding or chattering) and if I hit +, sometime it goes -, sometimes +.

I read through all the troubleshooting steps on the forums here and the assembly instructions.
I read through all the troubleshooting steps on the gShield and grbl pages.
I tried many (if not all) of the things suggested on the forums/wiki pages referenced above, no change in behaviour.
(traced wiring, verified all connections, verified play, tried changing some of the grbl settings, changed them back, etc.)

I've been controlling it with my Mac, so in order to eliminate the Mac as the problem, I scavenged an old laptop and got it running Ubuntu.
Using the Universal g-code sender on the "new" laptop, it exhibits the same behaviour.
X and Y operate properly, Z is flaky/crazy.

Today, I figured I'd swap the X and Z axis at the terminal blocks.
With everything disconnected, I moved the gantry to the center of the workspace.
Connecting everything up, I once again tried the manual control.

Since Z and X were now swapped, I tried a couple Z+ (now that the former X-stepper is connected to the Z-axis) and everything moves smoothly.
I tried many more Z+ and Z- and everything moves smoothly.

Buoyed by this slight success (yay, the wiring from the terminal blocks / motor/threaded rod/delrin nut is NOT the problem), I tried to jog the X-axis.
Instant dismay! Now the X-axis is the one that is crazy / flaky.
Multiple X- or X+ now sometimes move left, sometimes right (read: multiple X- = left or right, no discernible pattern).
X-axis is now intermittently making the loud chatter / grinding noise... other times, no noise, no movement.

In all these cases, the Arduino / gShield is powered up for the test, then disconnected, so I'm pretty sure I can (temporarily) ignore the possibility of overheating.
I'm doing maybe one 20-40 second test a couple times an hour.

At this point, I think I have to assume the Arduino or the gShield is the problem.

I'll rummage around for another Arduino Uno so I can load it with grbl to at least have the possibility of eliminating the Arduino from the list of suspects.

Based on the above, I think I've eliminated:
- The control computer
- the stepper motors
- the wiring between the terminal blocks and the stepper motors
- the USB port on the control computers (tried at least two on each computer)
- the ... I was going to write USB cable, but realized I hadn't tried a different one.

I'm going to leave this up here in case it helps others as I haven't seen the USB cable mentioned anywhere else...
...but @#$@#$@#$!!!!!!! I've just tried a different USB cable and the grinding / chattering has gone away.
Z+ and Z- now do + or - respectively, with no surprise opposites every now and then.

Now I just need to sort why when it's running the helloworld2.nc (or helloworld2mm.nc) it seems to sometimes go up, sometimes go down with the Sharpie (sometimes giving me a letter or two... then "air printing" the rest).

Taking a break for some food! Realized I haven't eaten in the last 9 hours. Then I'll try working through the normal troubleshooting steps again (adjust current, re-re-re-re-verify all wiring, re-verify all grbl settings again, etc.).
Shapeoko 2 (stock)

tjshape
Posts: 155
Joined: Wed Oct 01, 2014 1:59 am
Location: Madison, WI

Re: Help sorting a "Hello World" problem

Post by tjshape » Fri Dec 26, 2014 9:25 pm

Have you adjusted the power level on the controller for the z-axis (now the x-axis)?
Shapeoko 2, ACME upgrade, Belt Drive Z-Axis upgrade, Dewalt DW660

tylorch
Posts: 3
Joined: Fri Dec 26, 2014 7:31 pm
Location: Montreal, QC, Canada

Re: Help sorting a "Hello World" problem

Post by tylorch » Sat Dec 27, 2014 11:25 am

Hi, thanks for the suggestion!
I'm normalizing everything (except the USB cable that came with the kit.. that is now happily residing in my garbage can!!) before additional troubleshooting.

I figure in the event I need more help, it'll be easier on all of us if I'm not referring to "new x" or "new z" and "old x" or "old z"..!
(and possibly save reiterating the whole back story)

Post-USB cable swap, I've already set the pot on the Z-axis back to its original position.
I'll put that at the top of my list for this afternoon when I can get some more time to work on this.
Shapeoko 2 (stock)

tylorch
Posts: 3
Joined: Fri Dec 26, 2014 7:31 pm
Location: Montreal, QC, Canada

Re: Help sorting a "Hello World" problem

Post by tylorch » Sat Jan 03, 2015 1:03 am

Looks to have sorted it out, I've got the Z-axis pot "up" almost 2 points from the default start value.
Hello World largely a success. :D
(Sharpie was pretty much ruined by earlier troubleshooting, so used pencil / pen...)

Thanks for the suggestion, tried that first!
Going to go read some more to try to fully grasp where the third 0 (Z) is for 0, 0, 0....
Tomorrow (hopefully) I'll dig up some scrap lumber and run some tests on wood.
Shapeoko 2 (stock)

Post Reply