Page 1 of 1

HeeksCNC units

Posted: Sat Jul 12, 2014 7:30 pm
by SmokyRick
Has anyone else had trouble dealing with HeeksCNC as far as the units of measure? I draw in Progecad or Autocad. I am in inches, but it is generic units. When I import my dxf into HeeksCNC it comes in as mm. Not sure how to proceed without scaling everything up by 25.4 times. Then if I go back to it, I probably won't remember that it is scaled up without problems there. I don't think in millimeters. It just takes this old brain time to deal with a new system like that.
I would appreciate any suggestions as to how to proceed, or how you guys handle the change.

Re: HeeksCNC units

Posted: Sat Oct 11, 2014 9:59 pm
by aeleus
Any resolution to this?

I'm trying HeeksCAD/CNC, and it seems promising. I've run into the same issue. I create an SVG of a 1-inch square in Illustrator, MakerCAM and Visio and they can all open them without a problem. Heeks seems to ignore the defined units and treat everything as millimeters.

From my limited experiments, Illustrator uses pixels for units. A drawing of a one-inch square in a 72 pixel/inch drawing is 72px x72px. Heeks imports that as 72mm x 72mm. The same drawing in MakerCAM uses inches and is 1in x 1in. Heeks imports that as a 1mm x 1mm square.

It doesn't matter what units I choose in Heeks. For example, when using inches the "1 x 1" square imports as 0.03937 inches (1mm).

Re: HeeksCNC units

Posted: Sun Oct 12, 2014 1:56 pm
by SmokyRick
No, not really. Been trying other cad softwares.

Re: HeeksCNC units

Posted: Mon Nov 03, 2014 1:51 am
by aeleus
After some experimentation, I determined that Heeks is very particular about what file formats it can import properly. I tried SVG and DXF from Illustrator, Visio, and Inkscape. The only format that has worked so far is DXF from Inkscape. Even that has to be very specific. When saving, only check "use ROBO-Master type of spline output" and set the base unit as mm.

I'm sure there are CAD programs that will work, but I'm just using drawing programs.