Page 1 of 1

Shapeoko 2 + Laser - Cant get working

Posted: Mon Oct 03, 2016 12:41 am
by Gooliez
Hi Guys, had my shapeoko 2 for a while and finally pulled out the laser i've had that i bought off ebay year and a half ago...

The laser i got was the one recommended on the WIKI
http://www.shapeoko.com/wiki/index.php/Laser_Cutter


I cant seem to get it working.

Power is working, the Fan is rotating
Laser is on when the TTL / Ground pin isnt attached to the Head unit ( see pic)
When i connect the TTL, the laser turns off, but fan still rotates

when i run the "Focus point" test in step 2 of the wiki, the system moves, but the laser doesnt "BURN" the test piece ( no light )

I've got the + TTL connected to Pin 12 of the Ardruino, - TTL connected to ground ( i've swapped them around to make sure they werent the wrong way like in the wiki )

i've got a 12v power Supply running to it. so there's enough power



do i need to do anything GRBL wise or anything to get the laser working, or have i connected something wrong somewhere ?

Also i know it's Dodgy mounting etc, For the time being i'm just trying to get the thing working, then i can work on the cosmetic stuff.. lol

Re: Shapeoko 2 + Laser - Cant get working

Posted: Mon Oct 03, 2016 4:41 pm
by cozmicray
What grbl version are you using?

See
https://jtechphotonics.com/?page_id=1100

A grbl version that supports laser should be used,
there is a command to put grbl in "laser mode"

Re: Shapeoko 2 + Laser - Cant get working

Posted: Tue Oct 04, 2016 10:17 pm
by Gooliez
pretty sure it's 0.8, however to be 100% sure i also tested on both pins 11 & 12, no difference

thanks for the reply, thought you guys had abandoned me

Re: Shapeoko 2 + Laser - Cant get working

Posted: Sun Oct 09, 2016 6:40 am
by lowrizzle
Are you using M3/M5 or M3 S10000/M5 to activate/deactivate the laser? M3 PWM settings did not work for me since I'm running mainline GRBL. My diode would not turn on unless I'm above, say, M3 S9000.

Re: Shapeoko 2 + Laser - Cant get working

Posted: Sun Oct 23, 2016 11:31 pm
by Gooliez
Sorry about late reply....

i'm just running the test run at the moment.



g21 (nn)
g0 x0 y0 z0 (zero point)

g3 (turn on laser)
g1 x10 (burn a test line)
g5 (turn off laser)

g0 x0 y2 z2 (go to the beginning of the next line)

g3
g1 x10 (burn another test line)
g5
(and repeat)