need help with stepper config

Discussion of linuxCNC (formerly knows as EMC2)
Post Reply
kmzero
Posts: 8
Joined: Sun Sep 09, 2012 4:15 pm

need help with stepper config

Post by kmzero » Wed Mar 13, 2013 11:49 am

Hello,

My name is Laurentiu and i am the proud owner of eShapeoko nr.50.Thank you Catalin for everything that you have done for me.
The problem is that i bought an 4 axis driver with parallel port CNC4X35A that is not having to much information in the User Manual and i am just learning how to use LinuxCNC.
My setup is:
-eShapeoko with dual Y drive
-Z is the stock one with M8 threated rod
-4 motors 400 steps per revolution
-CNC4X35A driver(i attach the User Manual)
CNC4x35a User Manual.pdf
CNC4X35A User Manual
(462.42 KiB) Downloaded 296 times
I need help to configure stepper config for my setup.I have managed to configure it but the problem is that the Hello World example is writing with letters of 1 cm high(i suppose that it should be bigger ones).

Thank you,
Laurentiu

edwardrford
Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL
Contact:

Re: need help with stepper config

Post by edwardrford » Wed Mar 13, 2013 1:23 pm

My guess is that your microstepping is different than what you think you have set it for.

For example: Maybe you think it's 4x, but it's really 8x. Basically, the system is only traveling about 1/2 the distance it should. Should be a pretty straight forward fix.

-Edward
Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

kmzero
Posts: 8
Joined: Sun Sep 09, 2012 4:15 pm

Re: need help with stepper config

Post by kmzero » Thu Mar 14, 2013 6:34 pm

Thank you for your advise.I have managed to configure the driver i think well enough.
I have one more question, what should be a good "maximum velocity" and "maximum acceleration" for this type of motor and driver (the 400 step/rev from Sparkfun) for the X, Y and Z?

Improbable Construct
Posts: 997
Joined: Tue Apr 10, 2012 3:21 am
Location: Fairhope, AL
Contact:

Re: need help with stepper config

Post by Improbable Construct » Thu Mar 14, 2013 7:45 pm

kmzero wrote: I have one more question, what should be a good "maximum velocity" and "maximum acceleration" for this type of motor and driver (the 400 step/rev from Sparkfun) for the X, Y and Z?
This is a trial an error sort of question. For maximum velocity start with 5000 mm/min or so, if it runs ok try a faster speed until you get to a point where the motors sound bad or miss steps. Once you hit that point turn it back down a bit.
As for maximum acceleration I have found that 1/10 of the maximum acceleration seems to work pretty good.
I run 10000 mm/min with 1000 mm/sec/sec acceleration. I am running 200 step/rev motors so your results may be different.
Shapeoko #Classified some of the bolts may be original parts.
Shapeoko 1 # ???? Stainless plates, still in the box.
Shapeoko 2 # 3926 not stock
Shapeoko 3 # 0003
Store:
http://ImprobableConstruct.com
Twitter:
https://twitter.com/ImprblConstruct

kmzero
Posts: 8
Joined: Sun Sep 09, 2012 4:15 pm

Re: need help with stepper config

Post by kmzero » Sun Mar 17, 2013 5:22 pm

hello,

thank you for your advise, i have a working machine now but i have some problems with the limit-homing switch.I have try to mount the limit-homing switches for the Y axes first but without luck.The switches are this ones http://makerslideeurope.com/limit-and-h ... witch.html and i have wired them in parallel Normaly Open to ground GND and Com to the Y axes pin on the driver board (second pin see User Manual in the first post) and in stepper config i have set up pin 12 for "Both Limit + Home Y" and on Y axis config." Home location = 3.0","Home Switch location = 0.0","Home search velocity = 20" and Home Latch direction = Same".The problem is that if let unchecked the box for Invert and i try to run linuxcnc i get an error that it s saying "joint 1 on limit switch error"(but at preview is showing an arrow in line with Y positioning) and when i check the box for Invert and i try to run the machine it's working but when i try to home Y axes it's going to the end off table and wants to go more.
Please give me some advise about how i should mount this limit-homing switches.

Thank you

madmanmoe
Posts: 53
Joined: Mon Jan 28, 2013 10:29 pm
Location: Greater London
Contact:

Re: need help with stepper config

Post by madmanmoe » Mon Mar 18, 2013 9:31 pm

It could be to do with the default homing sequence. There are lots of different ways that LinuxCNC can use home switches. One is to rapidly move until it hits the switch, go past it, then very slowly go in the opposite direction, until it is resting on the switch. If your limit switch is at the end of travel, this will cause the carriage to hit the end.
If you are using a combined limit / home setup then you need to set the sequence differently, so that it starts off very slow, then stops as soon as it hits the switch.

Unfortunately I can't help you with any of this. I got as far as mounting my limit switches, but then after glancing at the LinuxCNC documentation, decided I could wait to hook them up later.
I actually just have them hooked up to an LED so I can use them to more accurately manually home my machine.

The main point is, if you're sure that LinuxCNC is recognising the switch presses, then it'll be a config problem.
I'm sure someone else on here can be more helpful.
Also, as it seems to be a software issue, the LinuxCNC forum is full of really helpful people.
MadManMoe's Blog
eShapeoko #23 Dual Y, Dual X, Dremel 4000, Pololu a4988 steppers run from LinuxCNC

kmzero
Posts: 8
Joined: Sun Sep 09, 2012 4:15 pm

Re: need help with stepper config

Post by kmzero » Tue Mar 19, 2013 2:31 am

The problem is that i think Linuxcnc is not recognizing the switch presses.I have tried all sort of combination in config and with the switches NO or NC.but still the same error.I get an arrow in line with the axes for what i am trying to config but when i press the "Toggle Machine Power" i hear a click coming from the motor but nothing happens.
Any idea about this problem?

thank you

Post Reply