No more torque after pulley change

Discussion of tinyG control platform
Post Reply
PsyKo
Posts: 430
Joined: Thu Aug 30, 2012 8:42 pm
Location: France

No more torque after pulley change

Post by PsyKo » Wed Jul 30, 2014 12:07 pm

Hello,

I recently changed a few stuff on my Shapeoko.
I switch from v1 to v2 z axis, and also switch from MXL belts and pulley (20 teeth) to GT2 belts and pulley (16T)
I alsoupgraded my TinyG Firmware to the latest edge firmware.
After reconfiguring my TinyG board (lost settings while updating), I verified my settings :
Movement are ok (travel per revs are ok, so on...)

But I tried to mill Delrin, and it fails with 1mm passes and 8mm endmill (something I did a lot with the old setup).
So I can't imagine aluminium.... I even try to hold the differents axis, and it's pretty easy to hold them with hands.... Looks strange to me.

Few observations :
- The pulley are not slipping on the motor shaft,
- The motor shaft not turning when blocking the axis,
- The belts are correctly tensionned ( I guess),

EDIT : Power management is set to Always On, and Motor timeout is 180 seconds...

Does anyone have any idea about what to do ?

Thanks
Last edited by PsyKo on Wed Jul 30, 2014 12:49 pm, edited 1 time in total.
Shapeoko #736
Kress 800, Z Axis upgrade, dual Y, 600mm X&Y rails, metal spacers and V Wheels, home switches, 4th axis
Goko - Free CNC Control Software - http://www.shapeoko.com/forum/viewtopic ... 380#p44380

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: No more torque after pulley change

Post by cvoinescu » Wed Jul 30, 2014 12:36 pm

You say you lost the settings. One of the gotchas with TinyG is that, by default, the axes that are not moving have their motors disabled. This is bad for milling: you need the X and Y motors energized all the time the mill is moving, even if one of them is stationary. The motor power management settings are $1pm, $2pm etc., and you want them to be 1 or 2 (not 3). Also, you want $mt (the time the motors stay on) to be something other than 0 (5 seconds should do).
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

PsyKo
Posts: 430
Joined: Thu Aug 30, 2012 8:42 pm
Location: France

Re: No more torque after pulley change

Post by PsyKo » Wed Jul 30, 2014 12:46 pm

Thanks Catalin, but I already have those settings corrects.

X, Y and Z axis/motor have their power management mode to Always On and the Motor timeout (mt) is set to 180 seconds...
For information, Firmware build :435.10, Firmware version :0.970
Shapeoko #736
Kress 800, Z Axis upgrade, dual Y, 600mm X&Y rails, metal spacers and V Wheels, home switches, 4th axis
Goko - Free CNC Control Software - http://www.shapeoko.com/forum/viewtopic ... 380#p44380

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: No more torque after pulley change

Post by cvoinescu » Wed Jul 30, 2014 12:50 pm

Okay, then all I can think of is things you already checked -- belts, pulleys, connections, motor current. Unless you accidentally specified the wrong board type or version when you built the TinyG firmware...

If nothing works, I'd downgrade the firmware and apply your old settings (have you saved them?), just to eliminate that as a variable.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

aldenhart
Posts: 132
Joined: Tue Apr 10, 2012 2:17 pm

Re: No more torque after pulley change

Post by aldenhart » Wed Aug 06, 2014 5:15 pm

Can you please post your settings? Just capture a $$ output

PsyKo
Posts: 430
Joined: Thu Aug 30, 2012 8:42 pm
Location: France

Re: No more torque after pulley change

Post by PsyKo » Sun Aug 10, 2014 6:43 pm

Hello Alden,

Settings are below.
Actually I think I got it to work. Maybe it was because I haven't used the Shapeoko for a while, and I have to get used to itagain :)
I managed to mill aluminium, Delrin, and so on, with decent settings (0.20mm depth pass in aluminium @ 800mm/min)
I also tripled checked my V-Wheels and especially the spacing off several VWheels on same panel (I had to measure the washer to be sure they were almost the same. In the box, thickness ranged from 0.92 to 1.25mm)

So I guess I'm fine now.

But Alden, I'll have to send some bug report I've been having. Not sure why... Most likely stufs like "{"er":{"fb":435.10,"st":31,"msg":"st_prep_line() move time is NAN"}}"... I'll do it later on the TinyG forum...

Code: Select all

[fb]  firmware build            435.10
[fv]  firmware version            0.97
[hp]  hardware platform           1.00
[hv]  hardware version            8.00
[id]  TinyG ID                    9H3583-PXN
[ja]  junction acceleration 2000000 mm
[ct]  chordal tolerance           0.010 mm
[sl]  soft limit enable           0
[st]  switch type                 1 [0=NO,1=NC]
[mt]  motor idle timeout        180.00 Sec
[ej]  enable json mode            0 [0=text,1=JSON]
[jv]  json verbosity              5 [0=silent,1=footer,2=messages,3=configs,4=linenum,5=verbose]
[js]  json serialize style        1 [0=relaxed,1=strict]
[tv]  text verbosity              1 [0=silent,1=verbose]
[qv]  queue report verbosity      2 [0=off,1=single,2=triple]
[sv]  status report verbosity     1 [0=off,1=filtered,2=verbose]
[si]  status interval           250 ms
[ec]  expand LF to CRLF on TX     0 [0=off,1=on]
[ee]  enable echo                 0 [0=off,1=on]
[ex]  enable flow control         1 [0=off,1=XON/XOFF, 2=RTS/CTS]
[baud] USB baud rate              5 [1=9600,2=19200,3=38400,4=57600,5=115200,6=230400]
[net]  network mode               0 [0=master]
[gpl] default gcode plane         0 [0=G17,1=G18,2=G19]
[gun] default gcode units mode    1 [0=G20,1=G21]
[gco] default gcode coord system  1 [1-6 (G54-G59)]
[gpa] default gcode path control  0 [0=G61,1=G61.1,2=G64]
[gdi] default gcode distance mode 0 [0=G90,1=G91]
[1ma] m1 map to axis              0 [0=X,1=Y,2=Z...]
[1sa] m1 step angle               0.900 deg
[1tr] m1 travel per revolution   32.0000 mm
[1mi] m1 microsteps               8 [1,2,4,8]
[1po] m1 polarity                 1 [0=normal,1=reverse]
[1pm] m1 power management         1 [0=disabled,1=always on,2=in cycle,3=when moving]
[2ma] m2 map to axis              1 [0=X,1=Y,2=Z...]
[2sa] m2 step angle               0.900 deg
[2tr] m2 travel per revolution   32.0000 mm
[2mi] m2 microsteps               8 [1,2,4,8]
[2po] m2 polarity                 1 [0=normal,1=reverse]
[2pm] m2 power management         1 [0=disabled,1=always on,2=in cycle,3=when moving]
[3ma] m3 map to axis              2 [0=X,1=Y,2=Z...]
[3sa] m3 step angle               1.800 deg
[3tr] m3 travel per revolution    2.1170 mm
[3mi] m3 microsteps               8 [1,2,4,8]
[3po] m3 polarity                 0 [0=normal,1=reverse]
[3pm] m3 power management         1 [0=disabled,1=always on,2=in cycle,3=when moving]
[4ma] m4 map to axis              3 [0=X,1=Y,2=Z...]
[4sa] m4 step angle               1.800 deg
[4tr] m4 travel per revolution   75.0000 mm
[4mi] m4 microsteps               8 [1,2,4,8]
[4po] m4 polarity                 1 [0=normal,1=reverse]
[4pm] m4 power management         1 [0=disabled,1=always on,2=in cycle,3=when moving]
[xam] x axis mode                 1 [standard]
[xvm] x velocity maximum       1500 mm/min
[xfr] x feedrate maximum       1500 mm/min
[xtn] x travel minimum            0.000 mm
[xtm] x travel maximum          300.000 mm
[xjm] x jerk maximum           5000 mm/min^3 * 1 million
[xjh] x jerk homing           30000 mm/min^3 * 1 million
[xjd] x junction deviation        0.0100 mm (larger is faster)
[xsn] x switch min                0 [0=off,1=homing,2=limit,3=limit+homing]
[xsx] x switch max                1 [0=off,1=homing,2=limit,3=limit+homing]
[xsv] x search velocity        1000 mm/min
[xlv] x latch velocity          100 mm/min
[xlb] x latch backoff            20.000 mm
[xzb] x zero backoff              3.000 mm
[yam] y axis mode                 1 [standard]
[yvm] y velocity maximum       1500 mm/min
[yfr] y feedrate maximum       1500 mm/min
[ytn] y travel minimum            0.000 mm
[ytm] y travel maximum          220.000 mm
[yjm] y jerk maximum           5000 mm/min^3 * 1 million
[yjh] y jerk homing           30000 mm/min^3 * 1 million
[yjd] y junction deviation        0.0100 mm (larger is faster)
[ysn] y switch min                0 [0=off,1=homing,2=limit,3=limit+homing]
[ysx] y switch max                1 [0=off,1=homing,2=limit,3=limit+homing]
[ysv] y search velocity        1000 mm/min
[ylv] y latch velocity          100 mm/min
[ylb] y latch backoff            20.000 mm
[yzb] y zero backoff              3.000 mm
[zam] z axis mode                 1 [standard]
[zvm] z velocity maximum       1000 mm/min
[zfr] z feedrate maximum       1000 mm/min
[ztn] z travel minimum            0.000 mm
[ztm] z travel maximum          100.000 mm
[zjm] z jerk maximum             50 mm/min^3 * 1 million
[zjh] z jerk homing            1000 mm/min^3 * 1 million
[zjd] z junction deviation        0.0100 mm (larger is faster)
[zsn] z switch min                0 [0=off,1=homing,2=limit,3=limit+homing]
[zsx] z switch max                0 [0=off,1=homing,2=limit,3=limit+homing]
[zsv] z search velocity         800 mm/min
[zlv] z latch velocity          100 mm/min
[zlb] z latch backoff            20.000 mm
[zzb] z zero backoff             10.000 mm
[aam] a axis mode                 1 [standard]
[avm] a velocity maximum      48000 deg/min
[afr] a feedrate maximum      48000 deg/min
[atn] a travel minimum           -1.000 deg
[atm] a travel maximum           -1.000 deg
[ajm] a jerk maximum          24000 deg/min^3 * 1 million
[ajh] a jerk homing           24000 deg/min^3 * 1 million
[ajd] a junction deviation        0.1000 deg (larger is faster)
[ara] a radius value              0.0000 deg
[asn] a switch min                0 [0=off,1=homing,2=limit,3=limit+homing]
[asx] a switch max                0 [0=off,1=homing,2=limit,3=limit+homing]
[asv] a search velocity        6000 deg/min
[alv] a latch velocity         1000 deg/min
[alb] a latch backoff             5.000 deg
[azb] a zero backoff              2.000 deg
[bam] b axis mode                 0 [disabled]
[bvm] b velocity maximum       3600 deg/min
[bfr] b feedrate maximum       3600 deg/min
[btn] b travel minimum           -1.000 deg
[btm] b travel maximum           -1.000 deg
[bjm] b jerk maximum             20 deg/min^3 * 1 million
[bjd] b junction deviation        0.0100 deg (larger is faster)
[bra] b radius value              1.0000 deg
[cam] c axis mode                 0 [disabled]
[cvm] c velocity maximum       3600 deg/min
[cfr] c feedrate maximum       3600 deg/min
[ctn] c travel minimum           -1.000 deg
[ctm] c travel maximum           -1.000 deg
[cjm] c jerk maximum             20 deg/min^3 * 1 million
[cjd] c junction deviation        0.0100 deg (larger is faster)
[cra] c radius value              1.0000 deg
[p1frq] pwm frequency               100 Hz
[p1csl] pwm cw speed lo            1000 RPM
[p1csh] pwm cw speed hi            2000 RPM
[p1cpl] pwm cw phase lo           0.125 [0..1]
[p1cph] pwm cw phase hi           0.200 [0..1]
[p1wsl] pwm ccw speed lo           1000 RPM
[p1wsh] pwm ccw speed hi           2000 RPM
[p1wpl] pwm ccw phase lo          0.125 [0..1]
[p1wph] pwm ccw phase hi          0.200 [0..1]
[p1pof] pwm phase off             0.100 [0..1]
[g54x] g54 x offset               0.000 mm
[g54y] g54 y offset               0.000 mm
[g54z] g54 z offset               0.000 mm
[g54a] g54 a offset               0.000 deg
[g54b] g54 b offset               0.000 deg
[g54c] g54 c offset               0.000 deg
[g55x] g55 x offset             110.000 mm
[g55y] g55 y offset             110.000 mm
[g55z] g55 z offset               0.000 mm
[g55a] g55 a offset               0.000 deg
[g55b] g55 b offset               0.000 deg
[g55c] g55 c offset               0.000 deg
[g56x] g56 x offset             110.000 mm
[g56y] g56 y offset              20.000 mm
[g56z] g56 z offset             -10.000 mm
[g56a] g56 a offset               0.000 deg
[g56b] g56 b offset               0.000 deg
[g56c] g56 c offset               0.000 deg
[g57x] g57 x offset               0.000 mm
[g57y] g57 y offset               0.000 mm
[g57z] g57 z offset               0.000 mm
[g57a] g57 a offset               0.000 deg
[g57b] g57 b offset               0.000 deg
[g57c] g57 c offset               0.000 deg
[g58x] g58 x offset               0.000 mm
[g58y] g58 y offset               0.000 mm
[g58z] g58 z offset               0.000 mm
[g58a] g58 a offset               0.000 deg
[g58b] g58 b offset               0.000 deg
[g58c] g58 c offset               0.000 deg
[g59x] g59 x offset               0.000 mm
[g59y] g59 y offset               0.000 mm
[g59z] g59 z offset               0.000 mm
[g59a] g59 a offset               0.000 deg
[g59b] g59 b offset               0.000 deg
[g59c] g59 c offset               0.000 deg
[g92x] g92 x offset               0.000 mm
[g92y] g92 y offset               0.000 mm
[g92z] g92 z offset               0.000 mm
[g92a] g92 a offset               0.000 deg
[g92b] g92 b offset               0.000 deg
[g92c] g92 c offset               0.000 deg
[g28x] g28 x position             0.000 mm
[g28y] g28 y position             0.000 mm
[g28z] g28 z position             0.000 mm
[g28a] g28 a position             0.000 deg
[g28b] g28 b position             0.000 deg
[g28c] g28 c position             0.000 deg
[g30x] g30 x position             0.000 mm
[g30y] g30 y position             0.000 mm
[g30z] g30 z position             0.000 mm
[g30a] g30 a position             0.000 deg
[g30b] g30 b position             0.000 deg
[g30c] g30 c position             0.000 deg
Shapeoko #736
Kress 800, Z Axis upgrade, dual Y, 600mm X&Y rails, metal spacers and V Wheels, home switches, 4th axis
Goko - Free CNC Control Software - http://www.shapeoko.com/forum/viewtopic ... 380#p44380

aldenhart
Posts: 132
Joined: Tue Apr 10, 2012 2:17 pm

Re: No more torque after pulley change

Post by aldenhart » Tue Aug 12, 2014 4:47 pm

Thanks for posting the settings. If you can post the Gcode you were running that would be helpful. Also, if you have any idea where in the file the problem occurs (ideally a line number) that would also be helpful. Is the problem repeatable to a specific location in the file, or does it occur sporadically?- Thanks. Alden

Post Reply