Enable microstepping

Post Reply
scott216
Posts: 228
Joined: Thu Oct 10, 2013 12:35 pm
Location: New Jersey

Enable microstepping

Post by scott216 » Sat May 10, 2014 2:31 pm

On the PCB-Gcode forum someone recommended I turn on microstepping to reduce low speed vibration. I don't know anything about microstepping. How to I enable it? What config settings do I need to change? I've got a shapeoko 2 with GRBL v0.8c.
Shapeoko v2 with DW660
GRBL v0.9i
Location: New Jersey

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Enable microstepping

Post by cvoinescu » Sat May 10, 2014 6:18 pm

If you don't know, you probably have microstepping enabled.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

scott216
Posts: 228
Joined: Thu Oct 10, 2013 12:35 pm
Location: New Jersey

Re: Enable microstepping

Post by scott216 » Sat May 10, 2014 7:07 pm

cvoinescu wrote:If you don't know, you probably have microstepping enabled.
The stepping would be whatever Shapeoko 2 ships with. Here's my config file:

Code: Select all

$0=40.020 (x, step/mm)
$1=40.200 (y, step/mm)
$2=320.000 (z, step/mm)
$3=30 (step pulse, usec)
$4=500.000 (default feed, mm/min)
$5=500.000 (default seek, mm/min)
$6=252 (step port invert mask, int:11111100)
$7=255 (step idle delay, msec)
$8=25.000 (acceleration, mm/sec^2)
$9=0.050 (junction deviation, mm)
$10=0.100 (arc, mm/segment)
$11=25 (n-arc correction, int)
$12=3 (n-decimals, int)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$15=0 (invert step enable, bool)
$16=0 (hard limits, bool)
$17=1 (homing cycle, bool)
$18=96 (homing dir invert mask, int:01100000)
$19=25.000 (homing feed, mm/min)
$20=250.000 (homing seek, mm/min)
$21=100 (homing debounce, msec)
$22=1.000 (homing pull-off, mm)
Shapeoko v2 with DW660
GRBL v0.9i
Location: New Jersey

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Enable microstepping

Post by cvoinescu » Sat May 10, 2014 11:48 pm

You have 8x microstepping on the X and Y axes, and 2x microstepping on the Z axis.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

scott216
Posts: 228
Joined: Thu Oct 10, 2013 12:35 pm
Location: New Jersey

Re: Enable microstepping

Post by scott216 » Sun May 11, 2014 12:05 am

cvoinescu wrote:You have 8x microstepping on the X and Y axes, and 2x microstepping on the Z axis.
Thanks
Shapeoko v2 with DW660
GRBL v0.9i
Location: New Jersey

Post Reply