Page 1 of 2

Chilipeppr Auto-level Problem !??

Posted: Fri Feb 05, 2016 5:51 pm
by ArtFaks
Hi everybody,

Since three days, i tear my hair out trying to create my first PCB with Chilipeprr.

But so far, impossible to make a "Autolevel" properly, I don't understand where come to the problem but the z-axis don't stop very long after having run the "test probe".
As if contact is made randomly, that's really weird. I also note that the z-axis down closer to the "zero" when i've my hand placed on the spindle.

I'm sure this is a ground problem, but being very nil electronics i don't understand where is my wiring problem.

In an attempt to solve my problem, i've change my probe wires (connected to the SCL and GND pin of my CNC Shield Protoneer).

I also tested on another system that i keep for rescue (Arduino Uno + CNC Shield + Stepstick + Nema17 plugged on my 15V lab power-supply) and the "Autolevel" works fine.

I would like to inform that i already make several object with HDPE and wood without having problems with my machine.

Could you help me please, I'd love to understand where does the problem and how to solve it.

Could you help me please, I'd love to understand where does the problem and how to solve it.

PS: Pardon my language, i'm french !

Re: Chilipeppr Auto-level Problem !??

Posted: Fri Feb 05, 2016 6:31 pm
by cvoinescu
First, make sure the GND pin is connected to the endmill and the input (SCL) is connected to the board.

The easiest way to fix 90% of the problems is to add a 100 nF capacitor between GND and the input pin.

Re: Chilipeppr Auto-level Problem !??

Posted: Sun Feb 07, 2016 2:35 pm
by ArtFaks
Hi, thanks a lot for your help @cvoinescu,
i've followed your tips and so, I connected the "GND Pin" on my endmill and the "SCL/A5 Pin" on my PCB plate (in my previous test i do the opposite), and i've also add a capacitor 0.1uf between "GND Pin" and endmill wire.
It's better since now because the endmill go down and stops well as soon as it touch the PCB plate but now i'm confronted to another very strange problem.

When i run a "Auto-Level" cycle, this cycle stops at each point and i must click twice button pause to resume the cycle for the next point. i've also noticed and you will see on the attached photo after the "auto-level" cycle perform there like a small hole at each point of measurement on my PCB plate. It's really very light but i wonder if it's well normal.

I note also some problems with Chilipeppr ("Chrome" and "Firefox").
- Problems when importing "eagle" files. The files loading fine but doesn't reflect my circuit with all elements (holes, via, pads...) and has no "gcode".

Since my very first test, when i jog axes of my machine with movement controls of Chilipeppr, the axes move perfectly but the user interface always indicate always "x=0, y=0, z=0". Is this normal?
IMG_1383-privé.jpg (273.67 KiB) Viewed 4382 times

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 12:42 am
by rodcar125
I had some problems at first when I was trying to auto level. The program would run just fine at first but then it would kind of pause after each point and that pause getting bigger after some more probing points. The other problem I had was that the program "randomly" stopped working. No motion whatsoever and no error code.

After some testing I found that the stopped program problem was because I had the "Start probing at:" setting at the default 0.5mm. The very warped PCB and unsquared S3 of mine added up greater than that so when the program tried to start probing at 0.5 it was already touching the PCB and then didn't know what to do... The problem was corrected by changing that value to something like 1.5 or 2mm ( and clearance height bigger than that), it takes longer since there is more distance to travel at probing feedrate but at least it would finish now.

The other problem, the one that the probing sequence would pause after each point, was that the browser was getting very slow after every probing point ( saving the data) and plotting it in the window. What I did there was to disable the 3D viewer and the probing grid and preview while the probing process was being completed. I don't understand why this happens to me since I use a workstation with plenty of power ( or I believe so) and no other program running in the background but this helped a lot and finally get the probing data file in the "post-run" tab so It could adapt the original gcode file

Lastly, the marks on the photo seems that the connection is not being registered at time of contact between the probe and PCB. You could try cleaning the surface with some rubbing alcohol. I didn't have any markings on mine so I'm not sure how to help you there


Sent from my iPad using Tapatalk

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 10:43 am
by ArtFaks
Thank's for your reply and for your help.

Your informations and the return of your experiences will be very useful!

I'll redo an attempt and I come back here for you give news.

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 3:49 pm
by ArtFaks
After re-reading, i ask myself a question.
I made a picture to better understand!

Is this the first solution or second solution that i must use!

PS : I did my last tests with first solution.
Probe-Solution.png (75.25 KiB) Viewed 4326 times

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 3:58 pm
by cvoinescu
Second -- parallel, not series.

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 4:00 pm
by ArtFaks
Ok, thanks a lot

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 6:18 pm
by ArtFaks
Still the same problem when I run an auto-cycle level, it's alone stop after the first control point, I was forced to click the pause button to move to the next control point.

After having made the auto-level cycle completely (by pressing a pause button each time), I try to send the result to my gcode but I believe that nothing happens.

What I have done :
- So, I changed and set my 0.1uf capacitor in parallel (thanks cvoinescu).
- I clean my plate pcb alcohol (thanks @rodacar125).
- I change the default 0.5mm by 2.5mm (thanks @rodacar125)

- No more small hole visible on the surface of my pcb plate (thanks @rodacar125)
- The auto-level cycle is well positioned but I must click pause button always (it's just boring)
- The gcode result of auto-level will not be sending to my gcode and does not appear.
- Coordinates viewer doesn't indicate the real coordinates positions of my machine.
IMG_1387-privé.jpg (328.78 KiB) Viewed 4320 times
I don't understand anything, and it's starts to seriously annoying this story of "Chilipeppr!"

I sincerely believe that I will try to go through another software solution to create my PCB.

Still, I did a little test of my circuit with Chilipeppr and UGCS to see the difference.
You will probably wonder why I didn't continue to do my PCB with Chilipeppr, well simply because it stops by itself after 100 lines and then, well .... I don't really know that 'it happens.

Help would really appreciate, please!

My gcode in attached file.
(10.06 KiB) Downloaded 104 times

Re: Chilipeppr Auto-level Problem !??

Posted: Tue Feb 09, 2016 6:40 pm
by WillAdams
Try bCNC?