Page 1 of 2

Commands too long

Posted: Tue May 27, 2014 9:12 am
by Jamesw
Hello all,

I'm new to GRBL and Shapeoko too and have a particular 'command too long' issue I'm trying to solve.

I have set up my Shapeoko2 with the UGS and Meshcam running on a Mac.
I get the CAD data through Meshcam and in to the UGS with no issue but when I hit 'send' to stream the code to the Shapeoko I get a command reading:

Error while starting file stream: Command #8 too long (63 > 50) '(STOCK/BLOCK, 110.000, 110.000, 24.000, 55.000, 55.000, 24.000)'

Does anyone know why I am getting this error? I have already run the 'Helloworld' task fine and sorted out some XYZ axis challenges and thought everything was working well. Also the CAD data ran through to the UGS well - the viewer showed what I had modelled.

Thanks for any help anyone can bring and I hope I can return the favour as I learn more!

James

Re: Commands too long

Posted: Tue May 27, 2014 10:22 am
by WillAdams
It looks to me as if the comment is pushing the line out past the 50 character limit (and is reported at 63 characters).

My suggestion would be to delete that line and see if you can turn off the generation of such comments in MeshCAM --- or not to generate it, that's probably a function of the post-processor you're using --- which one are you using?

Re: Commands too long

Posted: Tue May 27, 2014 12:07 pm
by scott216
Are you using universal gcodesender? If you are using the latest version of universal gcodesender and GRBL, you can go into universal gcodesender setting and change the max line length from 50 to 70.

Re: Commands too long

Posted: Tue May 27, 2014 6:55 pm
by Jamesw
Thank you both for the quick replies. Scott216 you hit the nail on the head and that got over the issue right away.
Now cutting the first foam prototype and I already see the next question on the horizon but I'm going to trawl the blog and wiki first!

Thanks again for the assistance!
James

Re: Commands too long

Posted: Tue May 27, 2014 6:59 pm
by WillAdams
Please note that you've only addressed a specific iteration of this problem --- it's still possible for MeshCAM to create too-long comment lines, and UGS still doesn't handle shortening too-long lines properly if they're comments --- please file a bug report on the latter and look for a post-processor which fixes the former.

William

Re: Commands too long

Posted: Thu Jun 26, 2014 12:45 pm
by desks791
Hi, just delete the spaces and it will be 50, it seem only this line always more than 50, it works so far until someone can come up a alternative or permanent solution.

Re: Commands too long

Posted: Wed Oct 22, 2014 11:55 am
by joedeck868
Hello All,

I am fairly new to this as well and am encountering the same issue. I am using Eagle to generate gcode for a pcb board. The Gcode loads into Universal Gcode Sender just fine and I can see the traces through the visualizer. I receive a very similar error saying that the Command #6 too long (64>50)... when trying to send the gcode to my Shapeoko 2.

I have searched all over the web and everyone just keeps say to just extend the limit of characters available in the settings but no one describes how to actually do it.

Could someone tell me how to fix this issue step by step?

Thanks,

Joe

Re: Commands too long

Posted: Wed Oct 22, 2014 12:24 pm
by Schruminator
I'm on my work computer (and thus don't have UGS handy to look at), but I was thinking that on the more recent versions (1.0.7, 1.0.8) there definitely was a setting to truncate or round command lines that are too long.

Re: Commands too long

Posted: Wed Oct 22, 2014 12:25 pm
by scott216
joedeck868 wrote:Hello All,
I am fairly new to this as well and am encountering the same issue. I am using Eagle to generate gcode for a pcb board. The Gcode loads into Universal Gcode Sender just fine and I can see the traces through the visualizer. I receive a very similar error saying that the Command #6 too long (64>50)... when trying to send the gcode to my Shapeoko 2.
I have searched all over the web and everyone just keeps say to just extend the limit of characters available in the settings but no one describes how to actually do it.
Could someone tell me how to fix this issue step by step?
Thanks,
Joe
I don't have UGS on the computer I'm using right now, so I can't do a screenshot for you. But there is a setting section in UGS where you can change the maximum comment length. Are you using PCB_Gcode with Eagle? What's what I use.

Re: Commands too long

Posted: Wed Oct 22, 2014 12:25 pm
by WillAdams
It's an FAQ: http://www.shapeoko.com/wiki/index.php/FAQ#MakerCAM
G-Code previews okay, but circles and arcs are stair-stepped? --- Lines are too long. Turn on truncating lines in your Communication / Control program or edit them by hand or use a javascript wrapped up in a zipped up html file.
Links are to:

- http://www.shapeoko.com/wiki/index.php/ ... _/_Control
- http://www.shapeoko.com/forum/viewtopic ... 62&p=12345
- http://www.shapeoko.com/forum/viewtopic ... 62&p=12345

It's also addressed in more detail on the Operation Troubleshooting page: http://www.shapeoko.com/wiki/index.php/ ... m_Expected which has specific instructions for using the free text editor SCITE and a regular expression.

which links to: http://www.shapeoko.com/wiki/index.php/G-Code_Utilities which lists several tools for this.