Upgraded to GRBL 0.9f, now some things are funky

Discussion about the arduino based g-code interpreter, grbl
Post Reply
Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Fri Jul 18, 2014 7:58 pm

I've been in the process of enlarging my mostly stock SO2 to a full 1.8m square. It has been quite a project! The only real upgrade I had made before was to switch to a bosch colt spindle. Now I've made it a different beast:
-enlarged to 1.8m square
-beefed up the x axis with an extra 20x40 extrusion and bolted the whole assembly together
-built a bomber torsion box table (and working on making it collapsable for more efficient garage storage)
-added drag chain, limit switches, and a touch plate
-upgraded to an acme lead screw Z axis
-Added 2 additional v-rollers for the Z axis, along with a second motor mounting plate for increased rigidity
-Tweaked the Z geometry a bit to get a full 4" of travel (And mounted the Y rails high enough to allow for a 4" thick workpiece)
-Designed a custom dust shoe to be 3d printed for the bosch colt
-I'm probably missing some other things, this was a big project.

Anyway, to activate the touch probe I had to upgrade to GRBL 0.9e. As I was looking, I found that 0.9f is out, so instead I upgraded to that. I was at 0.9a before. Once I got it up and running, it took me some time to get my step port and direction invert masks working properly- all axes originally moved only in the positive direction, whether I entered a positive or negative coordinate.

So now the funky stuff:
1. 0.9f seems to have lost the setting for a default feed rate. This means that I can't just jog when I first connect- I must first enter a feed rate.
2. I'm having trouble getting homing working. This may be a 0.9f issue, or just the fact that I'm setting up homing for the first time. When I tell the machine to home, it first raises the z to the limit switch, but then stops and sets an alarm as though it was limiting. It doesn't even attempt to run the x or y since the machine is in the alarm state. All limit switches work properly, so it makes me think it is a setting issue.

Any thoughts on any of this?
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

scott216
Posts: 228
Joined: Thu Oct 10, 2013 12:35 pm
Location: New Jersey

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by scott216 » Fri Jul 18, 2014 8:02 pm

I upgraded from 0.9e to 0.9f and I had to redo all my config settings. I'm not having any of the problems you mentioned.

BTW - I love the touch probe feature.
Shapeoko v2 with DW660
GRBL v0.9i
Location: New Jersey

Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Fri Jul 18, 2014 8:08 pm

Scott,

Does 0.9f have a default feed setting? I don't see it in the list anymore, but maybe I missed it.
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

scott216
Posts: 228
Joined: Thu Oct 10, 2013 12:35 pm
Location: New Jersey

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by scott216 » Fri Jul 18, 2014 8:13 pm

I'm not sure, here are my settings for 0.9f (I'm using a stock Shapeoko 2 with limit switches)

Code: Select all

$0=40.020 (x, step/mm)
$1=40.200 (y, step/mm)
$2=320.000 (z, step/mm)
$3=500.000 (x max rate, mm/min)
$4=500.000 (y max rate, mm/min)
$5=500.000 (z max rate, mm/min)
$6=25.000 (x accel, mm/sec^2)
$7=25.000 (y accel, mm/sec^2)
$8=25.000 (z accel, mm/sec^2)
$9=288.000 (x max travel, mm)
$10=325.000 (y max travel, mm)
$11=80.000 (z max travel, mm)
$12=30 (step pulse, usec)
$13=4 (step port invert mask:00000100)
$14=224 (dir port invert mask:11100000)
$15=255 (step idle delay, msec)
$16=0.050 (junction deviation, mm)
$17=0.100 (arc tolerance, mm)
$18=3 (n-decimals, int)
$19=0 (report inches, bool)
$20=1 (auto start, bool)
$21=0 (invert step enable, bool)
$22=0 (invert limit pins, bool)
$23=0 (soft limits, bool)
$24=1 (hard limits, bool)
$25=1 (homing cycle, bool)
$26=96 (homing dir invert mask:01100000)
$27=25.000 (homing feed, mm/min)
$28=250.000 (homing seek, mm/min)
$29=100 (homing debounce, msec)
$30=1.000 (homing pull-off, mm)
Shapeoko v2 with DW660
GRBL v0.9i
Location: New Jersey

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by cvoinescu » Fri Jul 18, 2014 10:44 pm

Having a default feed setting is against the G-code spec. The program must specify a feed rate before there's any feed movement. GRBL 0.9f simply changed to be more in line with the spec; your host program should update too.

For homing, did you set up a back-off distance, enough to disengage the limit/homing switch?
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Fri Jul 18, 2014 10:59 pm

The fact that they removed the default feed makes sense. We still have the default rapid speed, which is machine dependent, not job dependent.

Good thought on the back off. I didn't notice it trying (I used the default 1.0mm), but I'll increase it to see if that makes a difference.
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

secretspy711
Posts: 175
Joined: Thu Jun 12, 2014 7:55 pm
Location: Colorado

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by secretspy711 » Fri Jul 18, 2014 11:26 pm

I flashed 0.9f and my machine would only move in one direction. Flashed back to 0.8c and everything is normal again. Can someone explain how the step and direction masks work? I suspect that's my problem.
Shapeoko 2 #5510: 1200 x 500 mm, Makita RT0701

Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Fri Jul 18, 2014 11:41 pm

That's the exact problem I had. I found that setting the step mask to zero, and the direction inversion mask to my original step mask value solved the problem for me. I can't explain the step inversion mask to you, though. That is a mystery to me too.
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Mon Jul 21, 2014 3:01 am

Just a quick update for anybody who may have had the same problem as me. I had wired my mechanical limit switches (micro switches) according to this schematic:
http://www.shapeoko.com/forum/viewtopic ... =10#p18968

The problem I was experiencing with homing not proceeding after the limit appears to have been caused by the connection via resistors to the +5v pin. I cut the resistors out of the circuit so the switches are purely pulling pins 9, 10, and 11 to ground, and everything is working beautifully.
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

Swarm
Posts: 13
Joined: Wed Jul 02, 2014 5:20 pm
Location: SLC, Ut
Contact:

Re: Upgraded to GRBL 0.9f, now some things are funky

Post by Swarm » Fri Jul 25, 2014 7:09 am

So I figured out the original issue. I somehow soldered my 5v jumper pin to the wrong hole. So my switches weren't referencing the necessary 5v for pull down. With the switches connected without resistors and no additional 5v, they we're susceptible to noise, this driving me to figure out the original issue.

So the moral of the story is to be careful where you connect the resistors. Get it right and things work well. Get it wrong, and you'll be scratching your head.
Heavily modified 1.8m square Shapeoko 2 with 2.2kW Chinese spindle, monster gantry, and 7" custom z axis.
Solidworks 2015 > HSMXpress or MeshCAM > Chilipeppr / TinyG

Post Reply