Stable GRBL 0.9g settings for full kit stock?

Discussion about the arduino based g-code interpreter, grbl
pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Stable GRBL 0.9g settings for full kit stock?

Post by pascualfuentes » Sun Aug 03, 2014 9:01 pm

Hi, I've purchased a full shapeoko kit and completed the build a couple weeks ago. When I first ran "Hello World" .nc file on 0.8c the machine ran fine (or so I thought.) When it came time to run my first job, the machine plunged too deep (or under-retracted when traveling to safety height) and went away trying to make a pass to then finally getting jammed. Must note that when trying to move the z axis by 1 step under the machine control tab in Universal Gcode Sender, the spindle jerks and chokes up, sometimes failing to travel at all. And I've also messed with the current as well to no success. So after a couple of weeks of searching through this forum trying to figure out if it's a mechanical or software issue, I decided to update my firmware to 0.9g because of the independent control of the feed and seek parameters (so I've read that this might be the issue). Now when I first flashed the arduino, the z axis moved just fine by 1 step, but the steps were a bit to huge (since I had yet to set xyz step/mm appropriate for my shapeoko). so after attempting to set the parameters based on the "Hello World" page (which is in 0.8c) I'm still stumped on what settings my max rate, accel, and max travel should be. Anyone out there who's gotten their full kit stock shapeoko to work with 0.9g, and would mind sharing their GRBL settings? Sorry for the n00bage, but so far this has been a very funstrating project :D Here are my current GRBL settings.
$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=28 (step port invert mask:00011100)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.100 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=250.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.020 (x, step/mm)
$101=40.020 (y, step/mm)
$102=320.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=100.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

jarretl
Posts: 135
Joined: Mon Feb 24, 2014 2:50 pm
Location: Edmonton, AB

Re: Stable GRBL 0.9g settings for full kit stock?

Post by jarretl » Sun Aug 03, 2014 9:59 pm

Hi,
Your settings look good, besides maybe increasing your max feed rates. I don't think 28 is a valid value for $2 in grbl 0.9g, you can probably just set that to zero.
(description for all settings can be found on the grbl wiki: (https://github.com/grbl/grbl/wiki/Configuring-Grbl-v0.9)

For max feed rates, I use 2500mm/min for x and y, and 500mm/min for Z. These feed rates also set how fast your seek movements (positioning the spindle before cutting) move, so I have mine set high to speed up the seek commands during a job. These speeds are too fast for cutting speeds in most material, but ensuring proper feed speeds are set in the cam program for each cut operation should be enough to ensure no actual cuts run at these speeds.
For accel, I have 50mm/sec^2 for x and y, and 30mm/sec^2 for z, but your settings should work as well.
Max travel only matters if you have homing and soft limits enabled ($20 and $22) so these settings shouldn't be of any consequence for you. If you had soft limits and homing enabled, they would simply be the max distance you can travel safely on any axis.
Shapeoko 2 #4043; DW660

txcas
Posts: 14
Joined: Thu Jul 31, 2014 12:50 pm

Re: Stable GRBL 0.9g settings for full kit stock?

Post by txcas » Mon Aug 04, 2014 5:10 am

$2 is definitely wrong, as stated above. Just set it to 0. In my case, the default $3=6 had the x and z axes inverted, I had to change that to $3=5. I also found that some settings like $3 do not work right away, and I had to soft rest GRBL (CRTL-X) for them to become active. I use GRBL Controller and under the Advanced tab you can soft reset GRBL. I left $11 and $12 to .9g defaults. Your other setting should work.

pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Re: Stable GRBL 0.9g settings for full kit stock?

Post by pascualfuentes » Mon Aug 04, 2014 7:06 pm

Hey thanks for the quick reply jarretl and txcas! I've taken your advice and changed $2=0, my xyz max rates to 2500, 2500, 500, and my xyz accel rates to 50, 50, 30. Yet I'm still having the same issue, but now my z axis motor is making a sort of "pulsing" noise and the z axis LED on the shield blinks along with it as well. Increasing the current speeds up the pulse, and decreasing slows it down. Is this normal? I've double checked the wiring with a multimeter and everything seems to be fine. I've loosened the M5 screws on the z axis motor mount plate to adjust the lead screw, though I doubt it is a mechanical issue. Moving 5 steps in either direction on the z axis results in the same jittered choked up movement I described earlier. Any other ideas I can try out? Thanks a ton

Current settings
$0=30 (step pulse, usec)
$1=255 (step idle delay, msec)
$2=0 (step port invert mask:00011100)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.100 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=250.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.020 (x, step/mm)
$101=40.020 (y, step/mm)
$102=320.000 (z, step/mm)
$110=2500.000 (x max rate, mm/min)
$111=2500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=30.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

txcas
Posts: 14
Joined: Thu Jul 31, 2014 12:50 pm

Re: Stable GRBL 0.9g settings for full kit stock?

Post by txcas » Tue Aug 05, 2014 3:23 am

My Z axis did something similar when I first built my Shapeoko. To test, I would disconnect the Z and X motors and connect the Z axis motor to the X motor stepper on the gShield. Try to move the X axis and see how the Z motor responds. Doing this "reset" my Z motor and it started working fine after that. Keep the voltage as low as you can, too much voltage is not good. Also be prepared to unplug the gShield just in case the Z axis tries to move too much when connected to X.

pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Re: Stable GRBL 0.9g settings for full kit stock?

Post by pascualfuentes » Tue Aug 05, 2014 9:39 pm

ok so I've plugged my z axis motor into the x axis and even changed my x axis maxrate to match my z axis maxrate (320.000) and voila it moved beautifully. no jerks at all. so then I switch back each motor to its appropriate terminal and re-entered the correct maxrate values for each axis...and still the same issue :? the z axis led on the shield is still blinking, now at a slower rate since I decreased the current and the motor jerks for a second then travels for bit, jerks then stops. never traveling to the same position. well now at least i know how the movement should look like based on its travel when connected to the x axis terminal. could it be my shield that is the issue? might there be something wrong with the z axis circuit? this is so frustrating! thanks for all the help guys. I'm really at a standstill here. I don't know what else to try :cry:

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Stable GRBL 0.9g settings for full kit stock?

Post by cvoinescu » Tue Aug 05, 2014 9:47 pm

There has been a batch of gShields with a manufacturing defect, where the Z axis was affected. Before you contact Inventables, check that the Z motor current is set to a similar value as that on the X axis (which works). If it still gives you trouble after setting the Z trimpot to the same angle as the one for the X axis, you probably got a bad gShield and should return it.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Re: Stable GRBL 0.9g settings for full kit stock?

Post by pascualfuentes » Tue Aug 05, 2014 10:33 pm

ok so setting the $1 step idle delay to 25 instead of 255 got rid of the blinking z axis LED and the pulsating motor noise. The z axis seems to travel fine when manually setting how many steps to travel under machine control. although when running a job, the z axis travels up fine, but then travels downwards in pulses and barely reaches the work piece, and then begins air cutting. any one have any ideas why $1 was the issue? and where I can go from here? you guys rock :D :geek:

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Stable GRBL 0.9g settings for full kit stock?

Post by cvoinescu » Tue Aug 05, 2014 10:38 pm

That sounds like overheating and thermal shutdown. Try reducing the motor current a little, and also try improving the cooling (reorient the cooling fan to blow more toward the Z axis, for instance).
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

Picengraver
Posts: 41
Joined: Sun May 11, 2014 5:05 pm
Location: Florida
Contact:

Re: Stable GRBL 0.9g settings for full kit stock?

Post by Picengraver » Tue Aug 12, 2014 2:59 pm

In my case, I had a Z axis lead nut that was drilled and tapped at an angle, putting a slight bind on the lead screw. This caused a problem for me similar to what you report. A new nut fixed my problem.

John Champlain

Post Reply