Stable GRBL 0.9g settings for full kit stock?

Discussion about the arduino based g-code interpreter, grbl
Posts: 115
Joined: Mon Feb 03, 2014 10:13 pm

Re: Stable GRBL 0.9g settings for full kit stock?

Post by cozmicray » Thu Sep 18, 2014 10:03 pm

GRBL 0.9 on Shapeoko 2
the Z axis setting for steps/mm
on my Shapeoko 2 with GRBL 0.9
it seems
$102=320.000 (z, step/mm) gives twice as much Z travel as commanded.

$102=640.000 (z, step/mm) seems to make Z axis travel accurate.

My GRBL stepper driver set to 8x (no jumpers)

Did GRBL 0.8 to GRBL 0.9 change stepper drive?


Posts: 135
Joined: Mon Feb 24, 2014 2:50 pm
Location: Edmonton, AB

Re: Stable GRBL 0.9g settings for full kit stock?

Post by jarretl » Fri Sep 19, 2014 2:32 pm

The calculation to determine 320 step/mm is based on 2x microstepping, so 320 is not correct for your setup.
If you are using 8x microstepping on your z axis, you would need to recalculate your $102 value using numbers specific to your machine with the calculations here: ... figuration

I don't think GRBL has changed how it uses the microstepping values, what you had set in 0.8c should apply equally in 0.9g. If you were using 320 step/mm in 0.8c, did you have it set to 2x microstepping then, and then take the jumper off your grblshield after the upgrade?
Shapeoko 2 #4043; DW660

Posts: 13
Joined: Thu Mar 26, 2015 4:20 am

Re: Stable GRBL 0.9g settings for full kit stock?

Post by 172pilot » Tue Jul 28, 2015 5:25 pm

I don't know if this was ever solved or not, but I also had unreliable stepper movement after upgrading to a 0.9 version, and the answer for me was to increase the step pulse duration ($0) although the setting I ended up with was 30, which is what you're set to now anyway.. It might be worthwhile to try a little longer pulse. I THINK the only downside is that the motor wont be able to move as fast, but I'm sure someone here will correct me if I'm wrong..??

Good luck!

Post Reply