GRBL + Arduino uno clone

Discussion about the arduino based g-code interpreter, grbl
Post Reply
RibbyPultz
Posts: 8
Joined: Thu May 24, 2012 2:57 pm

GRBL + Arduino uno clone

Post by RibbyPultz » Sat Aug 18, 2012 3:05 pm

Last night was supposed to be my moment where I finally saw my Shapoko come to life. Unfortunately I was thwarted in my attempt and now seek advice to see if I can fix what is wrong with my setup.

First the problem. Upon hooking everything up - laptop to electronics to Shapoko - last night I attempted to install GRBL on my arduino and issue the first simple commands to see the motors engage. Problem is that upon issuing those commands absolutely nothing happens. Unfortunately this means there could be a problem in any step between laptop and motor but I would like to ask about the GRBL installation first.

First potential problem, I thought I successfully flashed the grbl 0.8a hex file to my arduino but opening up gcoder for the first time my values did not match what they were supposed on the grbl wiki. On that wiki there is a line the says "If these values don't match click here" but that link seems to be dead. Not knowing if this was a big issue or not I proceeded to manually enter the values shown. Did I miss a crucial step here? One thing I have noticed is that when I start gcoder it does not say "grbl 0.8a" in the first line. That tells me that I am probably missing something but I followed that wiki pretty closely and don't see where I missed a step. Any thoughts?

Also the reason for the subject of this post. I ordered my Arduino from the Amazon market place, and even though the seller assured me it was a legitimate Arduino upon receiving I could tell that it was a clone. (An aside Amazon was spectacular in their customer service and provided a full refund and let me keep the product to boot) This being my first foray into anything Arduino I didn't know how to verify if the board worked or not so I just barreled ahead and put my electronics kit together thinking things would probably work out in the end. Now I am still 99% sure that the problems I am having are operator error and not the fault of the board but has anybody else had this problem? Or is there an easy way to run my board through it's paces to make sure it is working. Right now I am playing with house money so can just buy a new one to compare but I would rather verify if this one is working or not.

Also one last question in this very long post. One other thing I noticed when I was trying to get the motors to work (and failing) was this line from the "Hello World" wiki

Now, if you're ready, turn the power on to your Power Supply. You should hear a very satisfying "click" and "whooooosh" noise as your steppers engage. Great! We have power.

When I turned my electronics on I heard nothing from my steppers. Is this to be expected if I do not have the settings correct on my arduino/stepper shield (I am usuing the synthetos grblshield by the way). Or should I hear these engage regardless. If I should hear them regardless I obviously have a wiring problem somewhere (which would break my heart). But if I have to have the setting correct then that tells me where I need to focus my efforts.

I apologize for the massive post. Right now there seems so many variables to what could be going wrong. I am just trying to eliminate a few.

Thank you.

edwardrford
Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL
Contact:

Re: GRBL + Arduino uno clone

Post by edwardrford » Mon Aug 20, 2012 4:14 pm

RibbyPultz,

Thank for the detailed post! It's much easier to troubleshoot when we know what you have tried, not tried, etc. I'm appreciating it's structrue:
This being my first foray into anything Arduino I didn't know how to verify if the board worked or not so I just barreled ahead and put my electronics kit together thinking things would probably work out in the end.
I do the same thing, just carry on until you don't have any steps left, then see what pans out. Work backwards from there if something goes wrong :-)

Your clone arduino is probably not the problem. I'm guessing when you plug it in, your machine recognizes the device and the green (or blue) light turns on? If so, then you're probably golden there.

Loading grbl: Which program were you using? xloader? Did it give you an 'upload successful' message after the hex file had been pushed across the USB line? If so, then you're probalby golden there. If it didn't say v0.8 what did it say? If you do '$' then press enter, your arduino should spit back your settings along with the build info.

Manually entering the settings is fine. That's how we all did it until we recently figured out how to bake them into the hex file!

When you turned on the power did the grblShield light turn on? (I think it's a blue LED)

-Edward
Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

CKCKCKCK1
Posts: 1
Joined: Wed Jul 04, 2012 2:53 am

Re: GRBL + Arduino uno clone

Post by CKCKCKCK1 » Mon Aug 20, 2012 6:24 pm

RibbyPultz,
When I first set mine up, I ran into problems as well.

I used gcode sender, opened up the correct port, and hit $. Several settings popped up. Then, I tried manually typing a few things
x5
x0
y5
y0
z5
z0
I found that commands to X axis only moved it 1 direction, Z axis moved the Y stepper, and the Y axis did nothing.

I found that the pin outs were different than I was expecting.

It was something along the line of
XS,XD,YS,YD,ZS,ZD
vs
XS,YS,ZS,XD,YD,ZD

RibbyPultz
Posts: 8
Joined: Thu May 24, 2012 2:57 pm

Re: GRBL + Arduino uno clone

Post by RibbyPultz » Mon Aug 20, 2012 9:29 pm

Thanks for the replies. I had a little time to play with the electronics last night and think that I may have elimanated the arduino and uploading grbl from my list of problems. I was able to upload the "blink" sketch to my arduino (which worked) and have successfully uploaded grbl. When I uploaded grbl (using xloader) it said it was successfully upload and now it returns the proper settings when I enter "$". My Grbl shield lights up when power is applied and I have checked that it is receiving the proper amount of voltage.

So now I figure it must be a wiring problem and I will start working my way backward until I find out the problem. The reason that makes me want to cry is there is multiple steps to check as my path is Grbl shield to pin connectors to wires soldered to an xlr male connector (to get out of my electronics enclosure) this connects to xlr female connector soldered to wires which I then spliced/soldered to the stepper motor wires. Problably an overly complex setup for someone just starting out but I had some time before my kit showed up and at the time I thought I knew what I was doing :D (Lesson learned there)

I think my next step is to test things out and wire a stepper motor directly to the Grbl shield to cut out all of the intermediate steps and make sure that I understand the wiring correctly. I was hoping it was a software issue originally so I wouldn't have to tear things apart. Alas I guess I will get to practice my newly learned soldering skills a little more.

jsbannis
Posts: 80
Joined: Tue Apr 10, 2012 11:09 pm
Location: Chicago, IL

Re: GRBL + Arduino uno clone

Post by jsbannis » Mon Aug 20, 2012 9:53 pm

If you have a multimeter, it probably has a continuity testing mode that you could use to make sure the wire paths were okay without having to check each intermediate step. Just put one lead on where the wire connects to your grbl shield and the other where it connects to the stepper and if it beeps (or lights up, or displays something? not sure, mine beeps :)) then the connection is good.

Not saying it's a bad idea to eliminate the extra wiring to test, but if it would be a ton of work it might not be necessary.
shapeoko #0057

RibbyPultz
Posts: 8
Joined: Thu May 24, 2012 2:57 pm

Re: GRBL + Arduino uno clone

Post by RibbyPultz » Tue Aug 21, 2012 1:35 am

Good idea jsbannis

I was actually using a multimeter last night to try to test my electronics when my 3 year old "assistant" wanted to see it and promptly dropped it on the garage floor. Bad news there, but good news is now I will be able to buy one with a continuity tester and check that out before I start taking anything apart.

Post Reply