Inaccurate Z depths when running straight line tests

Discussion about the arduino based g-code interpreter, grbl
Post Reply
pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Inaccurate Z depths when running straight line tests

Post by pascualfuentes » Mon Sep 07, 2015 4:36 am

Hi, I'm experiencing an issue with my z axis for my stock shapeoko 2 running grbl 0.9g. I should mention that I've upgraded to a quiet cut spindle and put together an enclosure with proper fan cooling for the GRBL shield. Now when running a simple line test of 9 straight parallel lines cutting to a depth of -0.5 mm with a feed rate of 600 mm and a plunge rate of 200 mm on MDF wood, I believe my z axis is missing steps when it retracts and then plunges deeper than it thinks. Sometimes, it even retracts correctly, but then misses steps when plunging, resulting in a shallow cut/air cut. Now, I've read on the forums about people with similar issues and I've tried almost all of their solutions (collet tightness, adjusting current trim pot, aligning z axis rod, adjusting acceleration/max rate settings, proper fan cooling) and yet I still have the same issue. I've tried lowering z acceleration to no success. motor sounds like its grinding when it comes to a hault. at 50 it sounds smooth.

I'm using CamBam to generate my gCode. Has anyone experienced this/solved this issue? Could it be the GRBL shield? Hope not. Can some one look at my GRBL settings and GCode and verify? Also attached some photos of the cut results.

Code: Select all

Grbl 0.9g ['$' for help]
>>> $$
$0=30 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.050 (junction deviation, mm)
$12=0.100 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=250.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=40.020 (x, step/mm)
$101=40.020 (y, step/mm)
$102=320.000 (z, step/mm)
$110=2500.000 (x max rate, mm/min)
$111=2500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=50.000 (x accel, mm/sec^2)
$121=50.000 (y accel, mm/sec^2)
$122=50.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
$132=200.000 (z max travel, mm)

Code: Select all

( Made using CamBam - http://www.cambam.co.uk )
( Untitled 9/6/2015 9:05:19 PM )
( T0 : 3.175 )
G21 G90 G64 G40
G0 Z2.0
( T0 : 3.175 )
T0 M6
( Engrave1 )
G17
M3 S1000
G0 X10.0 Y10.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y50.0
G0 Z2.0
G0 X13.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y10.0
G0 Z2.0
G0 X16.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y50.0
G0 Z2.0
G0 X19.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y10.0
G0 Z2.0
G0 X22.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y50.0
G0 Z2.0
G0 X25.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y10.0
G0 Z2.0
G0 X28.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y50.0
G0 Z2.0
G0 X31.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y10.0
G0 Z2.0
G0 X34.0
G0 Z1.0
G1 F200.0 Z-0.5
G1 F600.0 Y50.0
G0 Z2.0
M5
M30
IMG_1308.JPG
cut from left to right
IMG_1308.JPG (83.87 KiB) Viewed 832 times
IMG_1309.JPG
IMG_1309.JPG (77.64 KiB) Viewed 832 times
IMG_1310.JPG
IMG_1310.JPG (74.01 KiB) Viewed 832 times

Georgei
Posts: 148
Joined: Mon Dec 22, 2014 11:22 pm
Location: UK

Re: Inaccurate Z depths when running straight line tests

Post by Georgei » Mon Sep 07, 2015 9:53 am

It looks like your Z axis motor coupler is loose. Check that first.

WillAdams
Posts: 8538
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Inaccurate Z depths when running straight line tests

Post by WillAdams » Mon Sep 07, 2015 11:35 am

Possibilities:

- Z-axis motor driving overheating --- adjust current and/or add fan
- acceleration set too high
- Z-axis coupler set screw loose as noted by Georgei --- Inconsistent operation may be caused by the flexible coupler being loose. Remove the set screws, rotate it 90 degrees or so and then replace the set screws.
- bit is pulling loose in collet --- must be more than hand-tight
- spindle getting pulled down --- tighten the mount, use a thicker or all-metal one

http://www.shapeoko.com/wiki/index.php/ ... ing#Z-axis

Check to make certain that the Delrin nut is secure and hasn't become loose/canted
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets
Nomad 883 Pro #596 (bamboo)

pascualfuentes
Posts: 8
Joined: Sun Aug 03, 2014 7:50 pm
Location: Valencia, CA

Re: Inaccurate Z depths when running straight line tests

Post by pascualfuentes » Mon Sep 07, 2015 11:42 pm

So luckily I have a friend who also has a shapeoko 2 stock and he offered to let me try his GRBL shield to see if maybe mine is bunk. So I switched them out and voila, it worked beautifully. I guess my Z-axis driver is bad..just emailed support about the possibility of getting a new one.

ijv
Posts: 71
Joined: Sun Apr 06, 2014 10:41 am

Re: Inaccurate Z depths when running straight line tests

Post by ijv » Wed Sep 09, 2015 11:23 am

This is not related to your original problem, but one thing that I noticed about your Gcode, is that if you are running a Quiet Cut spindle from Inventables. Then your spindle speed is set way too low at 1000 rpm, (M3 S1000), try setting it to something like 12,000 rpm and you should get some better cuts from it.

Post Reply