GRBL reboots when feed rate is over 6300mm/min ?

Discussion about the arduino based g-code interpreter, grbl
Post Reply
prensel
Posts: 4
Joined: Mon Jan 04, 2016 11:36 pm

GRBL reboots when feed rate is over 6300mm/min ?

Post by prensel » Tue Jan 05, 2016 7:56 am

Hi all,

I cant seem to set the feed rate higher then 6300mm/min. Any value higher results in an instant reboot from GRBL when jogging the axes with Xnn or G0 Xnn command.

Any known issue ?

Paul

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by cvoinescu » Tue Jan 05, 2016 12:28 pm

My GRBL seems to reboot when I exceed a certain step pulse rate, not a speed. If you want to go faster, try reducing microstepping (e.g. from 1/16 to 1/8), if your drivers support that. You'll need to adjust the steps-per-mm for those axes too (e.g. halving them).

This is not supposed to happen, by the way. GRBL used to know its maximum pulse rate and did not attempt to move faster than that. If you have a little time to characterize the problem, please file a bug on the GitHub issue tracker.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

chamnit
Posts: 376
Joined: Tue Aug 12, 2014 2:16 pm
Location: Albuquerque NM, USA
Contact:

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by chamnit » Tue Jan 05, 2016 4:47 pm

@prensel : @cvoinescu is right. Grbl has a 30kHz pulse frequency limit. It's specified on the grbl website, but it's not actively checked for in the firmware by default. It's mainly due to flash space required to make the calculations and do the checks. It's not a critical feature and was omitted intentionally. If I have the room, I'll cram it in there for the v1.0 release, but it's not likely.

prensel
Posts: 4
Joined: Mon Jan 04, 2016 11:36 pm

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by prensel » Wed Jan 13, 2016 9:31 pm

Okay, just noticed these replies on my problem..

I'm actually using servo motors with JenyTec controllers and these controllers also have a step-dir emulation mode.
I'm not sure where to look for this micro stepping setup...

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by cvoinescu » Wed Jan 13, 2016 11:04 pm

In that case, it would not be microstep, but something else, like steps per revolution. What you need is to reduce the number of steps to travel a certain distance, so that you can get to the speed you need without going over 30,000 pulses per second.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

prensel
Posts: 4
Joined: Mon Jan 04, 2016 11:36 pm

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by prensel » Thu Jan 14, 2016 4:24 pm

Okay, i can set the number of increments per step in the servo controllers.
I now have set 1 increment per 1 step but can set any value between 1-50.
The servo motors make 10.000 increments for one full rotation.
One full rotation of the x-axis is 25.4mm movement so i'm having 393.7 increments per mm.
Setting feed at 6300mm/min => 393.7 * 6300 / 60 = 41338 pulses per second... makes sense that it crashes..
By setting it to 10 increments per step i will loose some precision but gain more feed...
Maybe 5 increments per step will do fine, i need to experiment a bid :-)

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by cvoinescu » Thu Jan 14, 2016 4:55 pm

Yes, that's exactly the setting you need to play with, to get pulses-per-second below 30k.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

twforeman
Posts: 1347
Joined: Tue Jan 29, 2013 4:51 pm
Location: Minneapolis, MN
Contact:

Re: GRBL reboots when feed rate is over 6300mm/min ?

Post by twforeman » Mon Feb 29, 2016 4:29 pm

Kind of resurrecting a thread, but I realized on Saturday that I was having random feed rate related issues.

I'm using the Carbide 3D board and had my rapid rates set to 30,000. The machine was really moving, but when doing a combined X and Y move it would pretty consistently drop a bunch of steps and end up in the wrong location.

I finally figured out that it was feed rate related and recalled reading this thread. I set the rapid rates to 15,000 and all is well.
Ender 3 3D Printer
ShapeOko v3 serial #0004 - upgrade thread
All of my ShapeOko related blog posts

Post Reply