BCNC: My freezing problem solved - M7 was the villain

Discussion about the arduino based g-code interpreter, grbl
Post Reply
fheflin
Posts: 2
Joined: Fri Sep 16, 2016 11:56 am

BCNC: My freezing problem solved - M7 was the villain

Post by fheflin » Thu Feb 09, 2017 3:26 am

Using bCNC my jobs were stalling after a few steps in. It turned out that grbl was choking on the M7 code Fusion 360 was generating. No M7 No more problems.
Hope that helps someone. I had set the configuration to ignore the Tool Change code and was getting a little cranked when that didn't fix it. It was the M7 still left int the Fusion CAM Code.

Shook
Posts: 139
Joined: Thu Nov 12, 2015 6:50 pm
Location: Downingtown, PA

Re: BCNC: My freezing problem solved - M7 was the villain

Post by Shook » Thu Feb 09, 2017 5:02 am

Thanks. I know that I've had some stalls with F360 output in bCNC.

See also: http://www.shapeoko.com/forum/viewtopic ... 740#p64740
Shapeoko 3 (#1107)

chamnit
Posts: 376
Joined: Tue Aug 12, 2014 2:16 pm
Location: Albuquerque NM, USA
Contact:

Re: BCNC: My freezing problem solved - M7 was the villain

Post by chamnit » Thu Feb 09, 2017 3:38 pm

M7 is not a default supported g-code by Grbl. You can enable it, if you edit the config.h and uncomment the line `#define ENABLE_M7`. It's not enabled by default because it uses up the very last available pin on the Arduino Uno and not many people use it.

psoukup
Posts: 1
Joined: Fri May 13, 2016 2:45 am

Re: BCNC: My freezing problem solved - M7 was the villain

Post by psoukup » Sun May 07, 2017 11:36 pm

All, I just ran into this also, so I figured I'd leave a note for others reading this in search of an answer. The M7 command is related to coolant control. I went back to Fusion360, changed all my operations to coolant "Disabled" and output fresh g-code. All M7 commands were removed and this issue was resolved. -- Peter

Post Reply