Makercam wont follow path on the letter "L"

an open source, web based CAM package that works!
Mrevoir
Posts: 31
Joined: Fri Aug 22, 2014 4:21 pm

Makercam wont follow path on the letter "L"

Post by Mrevoir » Fri Aug 22, 2014 5:59 pm

Im trying to set up a follow path operation on some text. It all works fine except the letter L and part of the number 4.
Attachments
screen2.jpg
screen2.jpg (85.17 KiB) Viewed 1517 times

Mrevoir
Posts: 31
Joined: Fri Aug 22, 2014 4:21 pm

Re: Makercam wont follow path on the letter "L"

Post by Mrevoir » Fri Aug 22, 2014 6:00 pm

The view from makercam
Attachments
screencap.jpg
screencap.jpg (151.9 KiB) Viewed 1516 times

WillAdams
Posts: 8514
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Makercam wont follow path on the letter "L"

Post by WillAdams » Fri Aug 22, 2014 7:36 pm

Please post the SVG (you'll need to change the extension to .txt)
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)

Woodworker
Posts: 639
Joined: Tue Mar 11, 2014 1:37 am
Location: 5 miles north of Benson, NC

Re: Makercam wont follow path on the letter "L"

Post by Woodworker » Fri Aug 22, 2014 9:26 pm

I have had a similar problem with using the Hershey fonts extension. It would do everything but the straight vertical line on "d"s and "u"s. Went nuts for a few days and even started using p and flipping it as a d. I think I solved the problem by "ungrouping" the text an least once if not several times.
BRuce - SO2 #4798 - IC's Z axis upgrade, customized Z rail and Z motor mount, spindle Dewalt 611

Mrevoir
Posts: 31
Joined: Fri Aug 22, 2014 4:21 pm

Re: Makercam wont follow path on the letter "L"

Post by Mrevoir » Fri Aug 22, 2014 9:57 pm

I can't post the svg, currently at work. But now that you mention it, the text was grouped.

Woodworker
Posts: 639
Joined: Tue Mar 11, 2014 1:37 am
Location: 5 miles north of Benson, NC

Re: Makercam wont follow path on the letter "L"

Post by Woodworker » Sat Aug 23, 2014 1:46 am

Mine was not deliberately grouped but it still had to be ungrouped. I found an obscure google reference.
BRuce - SO2 #4798 - IC's Z axis upgrade, customized Z rail and Z motor mount, spindle Dewalt 611

Mrevoir
Posts: 31
Joined: Fri Aug 22, 2014 4:21 pm

Re: Makercam wont follow path on the letter "L"

Post by Mrevoir » Sat Aug 23, 2014 2:32 am

Well I ungrouped everything and it didn't seem to make a difference. Here's the svg.
Attachments
lee.txt
(7.42 KiB) Downloaded 130 times

WillAdams
Posts: 8514
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Makercam wont follow path on the letter "L"

Post by WillAdams » Sat Aug 23, 2014 3:09 am

Seems to be a bug where MakerCAM gets confused by points which are perfectly stacked on top of each other.

I split everything, joined it, and added some connecting paths and curves to keep that from happening:
Attachments
lee-partkamdesign-svg.txt
(10.04 KiB) Downloaded 180 times
lee.png
lee.png (10.49 KiB) Viewed 1463 times
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)

Mrevoir
Posts: 31
Joined: Fri Aug 22, 2014 4:21 pm

Re: Makercam wont follow path on the letter "L"

Post by Mrevoir » Sat Aug 23, 2014 3:00 pm

Wow thanks! If its not too much trouble, may I ask how you did it? I've been playing with it all morning, to no avail. I tried "break apart" and it gives me the same problem.

WillAdams
Posts: 8514
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Makercam wont follow path on the letter "L"

Post by WillAdams » Sat Aug 23, 2014 3:35 pm

You have to take each problem letter, i.e., ``L'' and:

- break it apart into two separate paths
- at the junction of the top paths, move the bottom-most point of the vertical stroke up a tiny bit and the left-most point of the horizontal over to the right a tiny bit
- (optional) draw in a path which connects the two --- if you look at the SVG you'll see that I made it an arc

I processed the #4 similarly, so that the paths didn't cross --- please look at the .svg (you'll need to remove the .txt extension and restore the .svg).
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)

Post Reply