Page 1 of 2

URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 2:08 pm
by philIam
Hey,

When I make the following profile makercam always send my machine for one absolutely WILD loop almost like its trying to F with me. then it continues on with its business.

GCODE ATTACHED GO NUTS ON IT!

But when that one wild loop happens it just shuts the machine down bc it dives into parts that it shouldn't.

I'm thinking this is a makercam code error, anyone else have this? Any solutions if its not makercam?

Thanks!

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 3:37 pm
by WillAdams
Not sure if this will help or no:

Remove the G40 --- it's not supported --- ditto for T0 M6 and M3 and M5 and M30.

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 4:07 pm
by criznach
M3 and M5 work but I don't think they'll do anything unless you use GRBL to turn your spindle on and off. But the others are not...

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 4:28 pm
by philIam
Iam using grbl. So you guys think that could be the issue.

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:27 pm
by criznach
philIam wrote:Iam using grbl. So you guys think that could be the issue.
I think G40 (cutter radius compensation) could cause problems if the rest of the code depends on it. EDIT: Maybe not, it looks like it's clearing any cutter offset. From the gcode it looks like your part is around 10" X, 2-3" Y, and 0.25" Z. Sound correct? Can you post a photo of what it did?

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:33 pm
by philIam
Hey,

Here it is.

It was just running fine then its like it caught an edge and just suicide dove. Which commands should I remove? Thanks!

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:37 pm
by philIam
That lighter J mark is just yet another anomalie that happens on first pass through and then never again... unless that deeper cut is it resurfacing... not sure.

My piece is smack dab in the middle of the working plane, if that helps.

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:39 pm
by Woodworker
Always at the same place? Did you have the issue with any other parts you have made?

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:41 pm
by philIam
Yea its always typically in the same place +/- a few mm's.

Yes, this has happened to me before but I have had symptom free cuts as well.

Re: URGENT ERROR - WILD LOOP!

Posted: Sat Aug 23, 2014 5:48 pm
by WillAdams
Random == mechanical failure most likely --- loose belt, slipping pulley --- might be electrical interference, or perhaps an under-powered or overheating stepper, but I don't think it's software.