S3 keeps over running the work space

Assembly questions and answers for the Shapeoko 3 CNC Mill
Post Reply
Frank741
Posts: 3
Joined: Sat Jun 27, 2015 7:34 pm

S3 keeps over running the work space

Post by Frank741 » Sun Jul 12, 2015 8:36 pm

I tried to air and print(with pen) the hello world gcode file. It seems like the jobs try to print 4X the size of what I expect it should and the machine hits the limit of the x axis.

I have tried to reset the origin

Grbl 0.9g
>>> $$
$0=10 (step pulse, usec)
$1=25 (step idle delay, msec)
$2=0 (step port invert mask:00000000)
$3=6 (dir port invert mask:00000110)
$4=0 (step enable invert, bool)
$5=0 (limit pins invert, bool)
$6=0 (probe pin invert, bool)
$10=3 (status report mask:00000011)
$11=0.020 (junction deviation, mm)
$12=0.002 (arc tolerance, mm)
$13=0 (report inches, bool)
$14=1 (auto start, bool)
$20=0 (soft limits, bool)
$21=0 (hard limits, bool)
$22=0 (homing cycle, bool)
$23=0 (homing dir invert mask:00000000)
$24=25.000 (homing feed, mm/min)
$25=500.000 (homing seek, mm/min)
$26=250 (homing debounce, msec)
$27=1.000 (homing pull-off, mm)
$100=250.000 (x, step/mm)
$101=250.000 (y, step/mm)
$102=250.000 (z, step/mm)
$110=500.000 (x max rate, mm/min)
$111=500.000 (y max rate, mm/min)
$112=500.000 (z max rate, mm/min)
$120=10.000 (x accel, mm/sec^2)
$121=10.000 (y accel, mm/sec^2)
$122=10.000 (z accel, mm/sec^2)
$130=200.000 (x max travel, mm)
$131=200.000 (y max travel, mm)
132=200.000 (z max travel, mm)

any tips or troubleshooting suggestions

dws
Posts: 15
Joined: Tue May 19, 2015 2:04 am

Re: S3 keeps over running the work space

Post by dws » Sun Jul 12, 2015 10:04 pm

It appears that many of the default settings are wrong. Try setting them to the correct defaults and see if that fixes the problem. http://docs.carbide3d.com/article/38-sh ... l-settings

Frank741
Posts: 3
Joined: Sat Jun 27, 2015 7:34 pm

Re: S3 keeps over running the work space

Post by Frank741 » Mon Jul 13, 2015 12:27 am

that did it
thank you

FabricatorCraig
Posts: 58
Joined: Fri Jul 27, 2012 3:17 am

Re: S3 keeps over running the work space

Post by FabricatorCraig » Mon Jul 13, 2015 5:57 pm

@Frank

Did you, by any chance, try using Inventable's Easel software on your SO3? People have seen problems with Easel overwriting the default SO3 settings with values conducive to SO2's and/or X-Carves.
-----------------Craig The Fabricator-----------------
SO1 - (1) Red Powder-Coat & (1) Non-Painted Steel
SO2 - (2) w/ lots of I.C. & other upgrades
SO3 - Serial #447

Post Reply