Shapeoko 3 Ignoring my Limit Switches

Assembly questions and answers for the Shapeoko 3 CNC Mill
Post Reply
dws
Posts: 15
Joined: Tue May 19, 2015 2:04 am

Shapeoko 3 Ignoring my Limit Switches

Post by dws » Thu Aug 13, 2015 4:27 pm

I have installed limit switches on my Shapeoko 3. When jogging, the machine will run right through the limit switches. Isn't it supposed to stop when it hits any of the switches? Is there something that I need to do to activate the switches? The switches appear to be working since the voltage measures 3.3 volts, and goes to 0 volts when switched.

David

CastIrony
Posts: 650
Joined: Mon Jul 21, 2014 10:21 pm
Location: Portland, OR

Re: Shapeoko 3 Ignoring my Limit Switches

Post by CastIrony » Thu Aug 13, 2015 4:46 pm

Limit switches are controlled by the $21 Grbl setting. This is set to 0 by default, set it to 1 to enable limit switches.

You might also look at settings $22-27 (which control homing) and $20 (which controls soft limits).
Shapeoko 3 #192 - Complete! Needs limit switches.

dws
Posts: 15
Joined: Tue May 19, 2015 2:04 am

Re: Shapeoko 3 Ignoring my Limit Switches

Post by dws » Thu Aug 13, 2015 5:42 pm

CastIrony,

Thanks! The limit switches and homing are working now.

David

Post Reply