Is my SO3 Dead?

Assembly questions and answers for the Shapeoko 3 CNC Mill
Post Reply
ptchan5
Posts: 35
Joined: Fri Feb 05, 2016 7:29 am

Is my SO3 Dead?

Post by ptchan5 » Mon May 09, 2016 10:44 pm

Since running my SO3 the last couple of months I have had my share of trials of tribulations. The biggest complaint has been the random freezes, which forces you to reset all the zero settings and recut whatever you had on the table.

The freezing comes from static shock when using a vacuum, loss of communication via the USB connection, and who else knows what.

But, while trying to figure out if I could eliminate these freezes, my SO3 seems to have lost USB communication permanently. I tried putting my DW611 on a separate circuit breaker from the SO3 and running the power and vacuum hose 90 degrees from the machine; being careful not to touch any metal surfaces while cutting. None of it had helped. Even went as far as to add two ferrite cores to the supplied USB cable and guess what happened, nothing. It made no difference, in fact it was when my SO3 froze in the middle of the cut and I had to disconnect the USB cable to reset the machine.

Now i'm dead in the water, because the Mac laptop or PC laptop won't recognize when the USB cable is inserted.

I reached out to carbide3D, hopefully they'll send me a new board so I can get this job finished. What a nightmare.

Peter

WillAdams
Posts: 8618
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Is my SO3 Dead?

Post by WillAdams » Mon May 09, 2016 10:48 pm

If it won’t communicate w/ multiple machines, and you’ve tried a known good cable, then it’s likely the board — they should replace it.
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

ptchan5
Posts: 35
Joined: Fri Feb 05, 2016 7:29 am

Re: Is my SO3 Dead?

Post by ptchan5 » Mon May 09, 2016 10:52 pm

Will, is this a known problem with a few bad boards? Because I've had issues since day one with freezing and such. Yet I read people have run their machine reliably one project after another. I really want to like this machine, but it seems to be anything but straightforward.

Carbide3D did respond recently and told me they would send me a new board. Just hope it isn't a chronic problem.

Thanks,
Peter

WillAdams
Posts: 8618
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Is my SO3 Dead?

Post by WillAdams » Tue May 10, 2016 12:04 am

This seems to’ve been a problem w/ the initial board revision for some people. You’ll get a new board w/ a capacitor which addresses it. If it doesn’t support will work w/ you until it’s resolved.
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

Post Reply