GRBL Setup for Shape0ko 3

Assembly questions and answers for the Shapeoko 3 CNC Mill

GRBL Setup for Shape0ko 3

Postby JenTaylor » Tue Aug 02, 2016 4:45 am

I have been trying to configure Carbide Motion to the Shapeoko 3. Assembley of the machine has been completed without any dramas. Electronic fitted by a qualified electrician and all lights on the Electronic Board light up.

But getting the Cartbide Motion to talk to the Machine is problematic. These are the steps I have taken.
1} Read instructions on Wiki/GRBL and implemented installation instructions
2} Downloaded Carbde Motion for Windows 8
3] Downloaded Xloader using Uno(ATmega328) to set GRBL to Arduino with hex file provided from Carbide instructions.
4] Changed USB cable.
5] tried to configure GRBL to activate homing
6] reboot computer after each step
7) updated my graphics driver

Yet still I get this error when I open up Carbide Motion;
GRBL ERROR ; CUTTER NOT FOUND
Is there anything glaringly obvious I can not see here?
Many thanks in advance......
Attachments
Error messagee.png
Error messagee.png (53.87 KiB) Viewed 913 times
JenTaylor
 
Posts: 11
Joined: Mon Jul 25, 2016 8:01 am
Location: Western Australia

Re: GRBL Setup for Shape0ko 3

Postby WillAdams » Tue Aug 02, 2016 12:21 pm

Are you sure that the re-flashing went correctly?

It's my understanding that there's some trick to it --- a hidden button which must be pressed or some such.

Knowledgebase article on connection problems here: http://docs.carbide3d.com/article/56-ca ... ine-or-jog which includes links and notes for re-flashing.

D/l'ing the Grbl source, the full Arduino IDE and using that to re-flash is often suggested as the most reliable method. Note that it's possible to erase / corrupt the bootloader which then requires re-loading that, which requires a second Arduino or a special device.
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)
WillAdams
 
Posts: 8449
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15

Re: GRBL Setup for Shape0ko 3

Postby JenTaylor » Wed Aug 03, 2016 3:36 am

Hi there, just checking we re on the same page. My electronic board is red from spark fun. Does that make any difference...?
JenTaylor
 
Posts: 11
Joined: Mon Jul 25, 2016 8:01 am
Location: Western Australia

Re: GRBL Setup for Shape0ko 3

Postby WillAdams » Wed Aug 03, 2016 11:20 am

| don't think there's a button, but otherwise, things should be pretty much the same.
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)
WillAdams
 
Posts: 8449
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15

Re: GRBL Setup for Shape0ko 3

Postby mrTheWheel » Thu Aug 11, 2016 2:49 pm

JenTaylor wrote:Hi there, just checking we re on the same page. My electronic board is red from spark fun. Does that make any difference...?

Yes it does!

In order for the Stepoko to work with CM you have to request for an Activation Key.
mrTheWheel
 
Posts: 5
Joined: Mon Jul 25, 2016 11:05 pm

Re: GRBL Setup for Shape0ko 3

Postby reibuehl » Tue Sep 06, 2016 1:11 pm

I have the same issue. Do you have a link to a description of how to request such an Activation Key? Or is it just an email to support?
reibuehl
 
Posts: 14
Joined: Thu Aug 11, 2016 11:17 am

Re: GRBL Setup for Shape0ko 3

Postby WillAdams » Tue Sep 06, 2016 1:15 pm

There's a knowledgebase article on how to enter it: http://docs.carbide3d.com/article/75-sp ... activation

I guess one just e-mails Sparkfun --- not sure why they wouldn't just send the code out w/ the controller.
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)
WillAdams
 
Posts: 8449
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15


Return to Shapeoko 3 Assembly

Who is online

Users browsing this forum: No registered users and 1 guest