Page 1 of 1

Z-Axis losing steps and sleepwalking stop command

Posted: Wed Feb 14, 2018 2:11 am
by kboruff
Hey all! I just got my machine and have setup and squared everything, but before I do any projects I wanted to make sure I have a workable wasteboard.

I have a piece of 1/2" MDF and I'm planning to drill and face mill that to finish getting everything ready.

I've been having some trouble with my new machine losing steps in Z as I am going through a drill command or if I start trying to contour the MDF edges to square angles. I made a short series of videos to show the trouble I'm running into and some of the stuff I've tried. I'm on the latest firmware because before I installed it my computer couldn't communicate with the Shapeoko 3. I'm on a Microsoft Surface Book and I'm using Fusion 360 to make the program and the stock Carbide Motion to send it.

Losing Z depth issue
https://youtu.be/xy-q4P4i7AM

https://youtu.be/8vogNOFipmQ

https://youtu.be/YAy7bFAu-yA

Additionally, I've found when I hit stop, the head will loop whatever the last motion command it received was.

Motion loop error when hitting Stop in the Run menu.
https://youtu.be/GwaQC52tsbE

I'm attaching the .NC files and the Fustion 360 file I made. I created the program in Fusion 360 with the Carbide 3D post processor.

Re: Z-Axis losing steps and sleepwalking stop command

Posted: Wed Feb 14, 2018 4:09 am
by WillAdams
For the Z depth, please check you Z-axis mechanically --- make certain that all the parts are in place and tightened suitably --- use thread lock where necessary on parts which don't need to be further adjusted, and that the belt is adequately taut (guitar string tight, but careful not to bend the motor mount shaft).

The lose of connection maybe EMI, see: https://www.shapeoko.com/wiki/index.php ... mendations