Machine and USG comms issues on Windows 10

Post Reply
CNC_Generals
Posts: 1
Joined: Tue Oct 25, 2016 6:07 pm

Machine and USG comms issues on Windows 10

Post by CNC_Generals » Wed Oct 06, 2021 8:27 am

Hi there - I think I'm in the right forum, apologies if not.

The short story is that I've been using an Arduino Uno (clone) for years as the brains behind my modified Shapeoko2, sending gcode from a Windows 7 laptop. Its been working brilliantly. However, I've just upgraded the laptop to Windows 10 and I'm regretting it big time...

I've been reading quite a few posts on various forums, trawling the internet, watching videos etc. Lots of people seem to have had similar issues, but none of the advice I've found is addressing my problem. I'm a bit lost frankly...

The first issue was Win10 showed the Uno as USB2.0 Serial in device manager.

I tried a few things here, trying to manually install Arduino drivers (with no joy) and eventually googling the Hardware Ids and installing some CH340 drivers. This gave me a Comm Port and I can see the UNO in the Arduino IDE. Progress?

Arduino8.PNG
Arduino8.PNG (81.49 KiB) Viewed 138 times



However, when I fire up USG there doesn't seem to be much in the way of communication. The software appears to be connected, on the correct port, but the machine is offline:

Arduino6.PNG
Arduino6.PNG (101.26 KiB) Viewed 138 times


I also tried this on an older version of USG (1.09), a backup of what I was using on Win7 all these years. The machine doesn't connect and hangs on 'INFO: Getting gcodefile." which I've been lead to believe means its not receiving grbl from the arduino.

Arduino7.PNG
Arduino7.PNG (60 KiB) Viewed 138 times


Anyway, I'm at a complete loss and would really appreciate any help or pointers people can give me.

I'm tempted to start from scratch now, but slightly worried I'm building on sand with Win10 and/or the laptop I have.

I'm hoping I'm doing something glaringly wrong and somebody here can help me.

Thanks in advance! :crossed_fingers: :crossed_fingers:

Post Reply