Page 1 of 2

motors just whine but don't spin

Posted: Mon May 06, 2013 8:16 pm
by venture
I had a problem similar to except I had no trouble physically spinning the motors by hand and the problem is with all the motors (sparkfun nema 17)

I built a stock shapeoko but when I would issue a GRBL command the motors would twitch (slight motion) but then just whine for an appropriate amount of time (x=1000 is 10 times longer than x=100) and then twitch again and turn off.

I thought maybe the motors didn't work but hooking one of them up to an LED and spinning by hand lights up the LED.

I tried reflashing a new GRBL (from .8a to .8c) with no results.

I ordered a new GRBL shield and stepper drivers (this time with heat sinks) with no results.

Turning the potentiometers does change the pitch of the whine and on my latest set I thought it even began to vibrate. Could someone confirm that for a 12.5v power supply a pot should read .860 when set to 2V on my multimeter. (I ordered a third set of stepper drivers I can try if there's a chance that's the issue but at this point I'm worried if something I'm doing may be killing them)

I tried shortening my hookup wire to the motor so it's just the motor leads going directly into the stepper driver ports to remove the chance of some kind of a crossed wire (at least on that motor).

I have rewired the order of the motor wires many times, ending up back at the canonical positions.

Still the motors just twitch on, whine for an amount of time corresponding to the GRBL command, and then twitch off.

Any ideas?

Re: motors just whine but don't spin

Posted: Mon May 06, 2013 11:28 pm
by Will Winder
I know you've tried a bunch of combinations already, but it still sounds like you have the motor wired up wrong.

Disconnect a motor and spin it by hand to get a feel for how much resistance there is. Then take a pair of wires and short them together, now spin the motor by hand again. Do you get more resistance? If no swap out one of the wires with one of the other two until you get more resistance.

Once the shorted pair makes the motor harder to spin you've found one of the coils, hook that up to A1 and A2. Now check that shorting the remaining pair also makes the motor harder to spin, hook that pair up to B1 and B2.

Now give GRBL another try.

Re: motors just whine but don't spin

Posted: Tue May 07, 2013 2:59 am
by danimal
I was doing some speed checks the other day and I could get my x and y axis motors to run at 11500 mm / min ( which is cool to watch) but anything beyond that they would slip causing them to whine and twitch just as you have described. Do you have your GRBL settings correct? When I would try to run the z axis it would not move at all because the poles were slipping so bad, and it is a more high pitched whine sound. If you have it wired wrong it sounds more like a grinding noise and vibrates. It would help diagnose the problem if you could shoot a quick video of it and post it. Right now I am leaning toward your $0, $1, $2 or $4 and $5 stored values for GRBL.

When I first flashed my GRBL I still needed to change some of the values. I know I had some problems with it initially because I had the wrong device selected in xloader, but even when I selected the right one and re-uploaded I had to go through and change several values to match what was in the wiki. If your values are correct, then I would move on to troubleshooting the wiring. The way that I do it every time that I disassemble my shapeoko (which is way too often still) is I measure the resistance between the wires, then the two pairs that have a very low resistance (~1.5 ohm) are your coils and I put them next to each other as a pair when wiring them to the stepper shield. Then I run a quick test and swap two of them on the same coil if it moves the wrong way.

Re: motors just whine but don't spin

Posted: Tue May 07, 2013 3:48 am
by venture
Thanks, I learned the trick to find the two coils but ultimately it was the GRBL settings. I guess as I was going through the instructions it did not register to me that there is a step "potentially change the initial GRBL settings" since apparently they were much too high. [EDIT: in particular $0, $1 and $2 were wrong) should have clicked this image ... ttings.png on this page ... g_Settings]

X and Y are moving nicely now!

Many thanks,


Re: motors just whine but don't spin

Posted: Sun Jun 16, 2013 11:17 pm
by mmmmmick2011
I have a similar problem, I think!
I am just going through the startup tests for Serial # 1782F
X and Z are working great, I even figured out how to reverse their direction.
But the problem with the Y is that the motors whirr for the right length of time, but the shaft does not turn.
Thinking that I may have set up the belt too tight, I have taken out the belt, but same issue (no load scenario)
I've played a bit with the current pots, but they don't change anything other than the intensity of the whirring sound.
grbl settings are identical to what is posted on the wiki - $0, $1 and S2 have the correct values

Any obvious things that I should check, or just start swapping steppers and trying to debug that way?

Re: motors just whine but don't spin

Posted: Mon Jun 17, 2013 1:01 am
by cvoinescu
Sounds like not enough current. Try to increase it a bit, but please follow the instructions for your board or driver on how to measure the reference voltage and how to calculate the current from that. (I admit to hardly ever doing that myself, just eyeballing it by the position of the trimmer pot, after having measured it once.)

Re: motors just whine but don't spin

Posted: Mon Jun 17, 2013 4:39 pm
by mmmmmick2011
I was able to sort out this problem, yay! In my case, it was the $6 port invert mask setting.
Since I had X and Z working correctly, I was able to troubleshoot systematically by swapping connections.
At the end, my conclusion was that the Shield, the wiring and the Steppers were all working correctly on X,Y and Z!
This left me with only one logical possibility - one of the setup variables.
Since I had to change the set up bits for both the X and the Z to get the right direction of travel, I tried changing the bits for the Y, and VOILA!
In this case I needed $6=11111100 (i.e., 252) for everything to work according to the wiki.

Re: motors just whine but don't spin

Posted: Mon Sep 23, 2013 5:37 pm
by mplonski
Hi, I seem to be having a similar problem.

I have a v4 grbl shield. I should note that the default GRBL settings were very different from the ones listed on the Run Your First Job page. 0, 1, and 2 were all 500, if I remember correctly. I have changed them to be identical to the recommended.

My X and Y axis are working perfectly. The Z axis is having trouble. When I type a command like "z=5" it jumps a little and then the grbl shield gets hung up. Most of the time one or both D2 and D3 will remain on and the shield will make a whining noise. I have swapped out the nema 17 servos, and it definitely follows the Z motor control.

The Z axis potientometer was initially set at just past minimum, but changing it to anything else doesn't make much of a difference. Occasionally I can get a command in for the Z axis that doesn't kill the machine, but it never moves enough to be correct. I have occasionally been able to send a second Z axis command, but rarely. Adjusting the pot changes some of the behavior, but it always dies.

Any suggestions before I try to get the grbl shield replaced? Thank you.


Re: motors just whine but don't spin

Posted: Mon Sep 23, 2013 8:16 pm
by cvoinescu
You may have entered the wrong value for $2. It depends on the microstep setting for the Z driver. If you have it entered as if for 8x, but your shield is set to 1x or 2x, it will try to move the Z too fast and fail. Another possibility is traverse speed too high, or acceleration too high. Try lowering both to see what happens. The X and Y will be slow too, but there's no helping that (except upgrading GRBL to 0.9a).

Re: motors just whine but don't spin

Posted: Mon Sep 23, 2013 8:19 pm
by Improbable Construct
I would check the alignment of the Z-axis and make sure it is running smooth.
The M8 rod can be bent, missaligned, or gunked up.
Also check the v wheel tension.