Page 12 of 20

Re: S3 stops mid-job

Posted: Wed Jan 20, 2016 6:37 am
by jbc
I posted on an earlier discussion about the success I had eliminating the drops.
I plugged my router into a 'Tripp lite' surge protector ... B0000510Z9

I have my shop-vac (hooked up to a dust shoe) plugged into the Tripp Lite too.
One switch turns them both on and off. And the best part -NO MORE disconnects.... and less mess.


Re: S3 stops mid-job

Posted: Fri Jan 22, 2016 3:18 am
by jfdotcom
I'm not sure how "hard" of a job it takes to do a disconnect if indeed that is the problem.

I am cutting a circle into plywood about 13" in diamter, 1/8 bit 60ips. I did a re-zero (close but not exact) and started the cut again so the bit only was cutting about half of the time. About 4 minutes in, I got a disconnect at a portion in which the bit wasn't touching any wood because it was cut the last time before the disconnect.

I did notice an oddity that after about 2 minutes, I closed/opened the port in UGS and I was again able to control the machine. Previously I had to cut power to the board and unplug USB before I could get it back.

Re: S3 stops mid-job

Posted: Sat Jan 23, 2016 12:50 pm
by aidenwolf
Just an observation, I have an SO2 and recently changed to tinyg from the cncshield/arduino/pololu driver setup.
I never had any mid-job stopping with the CNC shield setup (I had other issues though!), but get it quite frequently with TinyG.
Does anyone know why this would be?

Re: S3 stops mid-job

Posted: Sat Jan 23, 2016 1:53 pm
So,I have found a combo that works for me so far..

USB iso,grounded spindle holder(earth wire and a ground stake) and leave the laptop unplugged.

I could have everything in the workshop on including vac while cutting Alu with no stoppages.

Re: S3 stops mid-job

Posted: Sun Jan 24, 2016 1:44 am
by jfdotcom
I tried to cut a 9 minute job a few days ago and it couldn't finish (3" pocketed circle in plywood, 0.125 upcut bit, 0.2 plunge, 50 ipm).

I successfully cut the job 7 times back-to-back (usually 30 seconds of rest to jog to a fresh area of the material). I let the dust pile up so it should've been a static buildup/nightmare. After the cuts finished (I ran out of material), I jogged it out of the way, shop vac to everything including the waste board, frame, and router (virtually cleaned everything), no disconnects. Turned router on/off several times, still flawless.

- ferrite ring on router at plug end
- v2.3 PCB
- USB isolator
- Y axis grounded through end-plate screw, X axis bonded the same way to the same screw ran into a 5-15 plug
-- Impedance between receptacle and X and Y, 4 Ohms. Receptacle -> any area on Z (router body, mount, etc. ~15 Ohms)

I hope to do another couple hours of cutting tomorrow, perhaps a couple longer jobs instead before I stick a fork in the problem.

SADLY, the hour of cutting I did today nearly surpasses all of the combined cutting time I've done with this machine since it was received in July. My hopes are that the disconnects are behind me now.

Re: S3 stops mid-job

Posted: Sun Jan 24, 2016 7:53 pm
by UltiArjan
not a lot of news to add, just letting you know I also have disconnects... Just mailed "support"...

sofar, except for a very short test job I've not been able to finish a single job, not even a simple 15 minute job.... The
SO3/carbide motion always stops mid job. My machine is nr 1331 (the new electronics with no switches), I use it with the Makita RT0700

The things I already tried;
Run carbide motion from a win10 dell tablet (unplugged)
Run carbide motion from a win8 laptop (unplugged)
Plugin the shapeoko via a belkin surge protector (no idea if this thing filters anything, but just tried)
Plugin the makita via the surge protector.
Plugin the makita into a different power group (extension cord to another part of the house, not very practical).
Did all this also with the vacuum cleaner off

It stops at different points into the job every time.
I did plenty of "ballpoint" runs without ever having an error. (although on the win8 laptop I did get a "grbl error", and needed to plug into a different USB, the tablet never had any of this)
I ran air jobs with the makita off, without any issue.
when the makita was pluged into the same powerstrip as the SO3, it would stop in the beginning of a run, say first minutes.
When I plugged the makita in another power group it took longer (I already felt victorious..) but it still stopped after
about 15 minutes.

About the electronics, I notice my Ultimaker 3D printer has all the steppermotor wires twisted in
pairs, while the shapeoko steppers don't have this.... would it be wise to still do it? If so how
(which colors to combine in the twist?)

I'm using a 3dprinted ring to fit the makita into the shapeoko clamp (so it's isolated) do I need to replace it with aluminium?

I just read this whole tread, but I've got no time now to do any testing on the grounding, I had a look on at USB isolators and found many types, from 30 euro to very expensive... anything I can use to know which one is good?

Re: S3 stops mid-job

Posted: Sun Jan 24, 2016 9:00 pm
by WillAdams
AIUI, twisting the motor leads is a good idea, and shouldn’t have any negative consequences, so definitely worth trying.

I use an aluminum spacer, and have the old electronics, otherwise our machines are equivalent — if you’d like to try an aluminum spacer, I’d be glad to cut one up and send it to you.

Re: S3 stops mid-job

Posted: Sun Jan 24, 2016 10:20 pm
by jfdotcom
I just ran a 81 minute job pocketing out a 9" square down 3/4" deep in plywood without any issue. During the cut, (no dust collection at all so dust piled up a LOT), I used the shop vac to do the work surface, top of the router, rails, virtually everything I touched with the vac nozzle and my hand as well just TRYING to make it fail and could not. Cycling the router off/on several times after the cut, more of the shop vac, still no problem.

I know in the 7 months I've had the S3 to never say never but I'd like to hope that the problem is fixed -- at least 99.9% sure that I do.

Re: S3 stops mid-job

Posted: Mon Jan 25, 2016 7:59 am
by UltiArjan
jfdotcom wrote: - Y axis grounded through end-plate screw, X axis bonded the same way to the same screw ran into a 5-15 plug
-- Impedance between receptacle and X and Y, 4 Ohms. Receptacle -> any area on Z (router body, mount, etc. ~15 Ohms)
Can you please explain a bit more what you did here? maybe share some pictures?
After googl'in "5-15 plug (yep I'm european..) I understand you grounded the X, Y and router body all directly to the ground plug of a powerplug?

Re: S3 stops mid-job

Posted: Mon Jan 25, 2016 11:16 am
by aidenwolf
Good suggestions guys.

I've ordered an 'earth plug' and will ground the Y axis and X axis to it as jfdotcom did. ( ... Sw1ZBUs6UW)

I've also ordered a USB isolator to go between the SO2 and Laptop. ( ... b+isolator)

I've also ordered some Ferrite core clips to put around the router mill power cables, and cables going into the TinyG like others have done. ( ... e+core+8mm)

And failing all that, I'll buy an anti-static box to put the TinyG into. ( ... 22&sr=8-22) Might have to cut a hole for the fan and access the reset switch at the top (or would that render it usless?)

This anti-static issue seems to happen for me when I start running a second job, I don't have any problems running a 45 minute first job then as soon as I run anything after it just stops.