Page 17 of 20

Re: S3 stops mid-job

Posted: Thu Feb 04, 2016 1:28 pm
by aidenwolf
Just to add something, I added a Olimex USB isolator to my machine, and almost instantly I was getting disconnects of the TinyG to my laptop and messages on my computer saying 'USB device not recognized' and 'looking for drivers' (even though it says in the olimex instructions it doesnt need drivers). Shortly before these messages I was able to jog the machine around, but wouldn't stay connected for more than a few minutes.

Previously I had the same static issue as described in this post and thought an isolator may fix it, but obviously the Olimex one doesn't work. I've ordered the USB2ISO one with the Adum4160 chip as Catalin advised earlier in this post, so will try that one instead and use the machine without as normal without the Olimex as I did before. I've also grounded all the carriages and spindle, and added ferrite cores all over the place too.

I know someone else in this post tried the Olimex and it didn't work for them either, so maybe stay clear of that one for Shapeoko.

Re: S3 stops mid-job

Posted: Fri Feb 05, 2016 10:22 am
by aidenwolf
I ran a 3 hour job for the first time yesterday, and I took the Olimex USB isolator out of the equation, so it appears adding 9mm ferrite cores over the X, Y, Z stepper cables and one on each end of the spindle cable and also grounding my X, Y, Z carriages, and the outside of the spindle casing seems to have solved my issue (so far). I have ordered the USB2ISO USB isolator just in case too, but hopefully wont need it.

Re: S3 stops mid-job

Posted: Fri Feb 05, 2016 12:49 pm
by KAScnc
It appears that everyone has different results so it's probably safe to say that no one solution is the end-all. It's best to experiment to find the optimal solution.

I've finally corrected the locking issue for my system. /knockonwood

Changed power cable to ground the DW611 case.
Earth grounded inside/out vacuum hose, V78FH
Earth grounded computer case
Added ferrite cores to all steppers, router, vacuum, usb cable, and power supplies. (also added to my main compressor just in case)
Isolated the Stepoko heat-sink from the gantry with Kapton tape.
Placed router/vacuum on filtered surge protector.

Re: S3 stops mid-job

Posted: Fri Feb 05, 2016 2:44 pm
I just finished adding the cap to the board,finished a 2hr aircut with the spindle being flicked on and off,pulling the plug on the VFD and reinserting mid job (while on the same power strip as the PC and machine,just to add an extra difficulty rating) and she has kept on trucking.

This is with no ferrites,only a USB ISO (which im viewing with suspicion as its done very little thus far) and a surge protected power strip,Im going to load up some scrap alu and run a leveling program,hopefully that will be the end of it.

I must say,the response from C3D (via email) and other knowledgeable members here has been great,I thank you for that. Lets hope thats the end of that gremlin. :D

Re: S3 stops mid-job

Posted: Fri Feb 05, 2016 11:03 pm
by UltiArjan
Just did the first short (15min) cut with the 2.3 board. No problems, no disconnect.
Obviously only 1 small cut, but feeling optimistic. Also turned the makita on and off a few times, no problem.

What I did;
- replaced 2.2 board by 2.3
- twisted all motor wires
- separated the power and usb cable
- installed a printed top & bottom electronics cover (probably unrelated... will share the design later this weekend)
The makita was on the same wall outlet as the SO3, just the SO3 on a Belkin surge protector.
I did NOT do any extra grounding on the machine.
Twist.jpg (92.41 KiB) Viewed 2641 times
Regarding twisting the wires, you do NOT need to take of the connectors, just pry the cables apart and twist by moving them between itself (hmmm... not sure this is very clear) I found it working best not the do the whole cable at once, but to first bundle some, twist, and than do the rest.
twister.jpg (52.12 KiB) Viewed 2641 times
Will do some more cutting later this weekend...

Re: S3 stops mid-job

Posted: Fri Feb 05, 2016 11:44 pm
by cvoinescu
Agree with the twisting method. Pass the connector between wires 2 and 3, which will twist together wires 1 and 2 one way, and wires 3 and 4 the other way. As long as that's red and blue twisted together, and green and black twisted together, it's fine -- it makes no difference that they're twisted in opposite directions.

However, you'll get a neater twist if you remove them from the connector, and allow the wire ends to rotate freely as you twist each pair together.

Re: S3 stops mid-job

Posted: Sat Feb 06, 2016 4:43 am
by 461oceanblvd
Just x-posted this over on the Discussion forum thread:

Hey guys. So, as I posted I have had the same issue as everyone else. So I decided I would see what I could do to eliminate the USB connection entirely, via bluetooth adapter or a couple of XBee units (per Jorge at Carbide's suggestion). As a first step, I bought an FTDI serial - USB adapter, just to make sure I could use the 6-pin connector on the Carbide Motion board (v2.1 is the one I have), and communicate to the cnc from my laptop. I don't think the Carbide Motion software will work using that port, but UGCS and bCNC do. I'm using UGCS for now.

This is the cord I bought. I'm sure you can get them cheaper elsewhere, but I happen to live 20 minutes from SparkFun hq so I could pick it up:

I plugged it in and started the project file I have been cutting about 30 times in a row with a disconnect within the first 5 minutes. Well, I am happy to report it has now been 38 minutes and there has yet to be any hiccup!

The router has gone under pretty heavy strain (forgot to change the cam file back to 40ipm... woops). I have cycled the router on and off to move a clamp. My furnace has come on and off. My air compressor has cycled (which even dimmed the lights), but it did NOT stop the Shapeoko! It's still going strong. Maybe it's just a fluke. Maybe the original USB cord is bad. Maybe, the usb port on the controller has some issues. I don't know, but I am happy I found a solution that finally seems to be working. Thought I'd post it here in case it might help someone else!


Re: S3 stops mid-job

Posted: Sat Feb 06, 2016 3:36 pm
by UltiArjan
Just did a another 5 small jobs, makita off/on inbetween, vacuum cleaner on/off in between, no disconnects at all :D

Re: S3 stops mid-job

Posted: Sat Feb 06, 2016 4:11 pm
by RoguePirin
UltiArjan wrote:Just did a another 5 small jobs, makita off/on inbetween, vacuum cleaner on/off in between, no disconnects at all :D
Sounds promising. Can you specify exactly which connector you hooked into on the Carbide Motion controller board, and which direction you plugged the connector?

Re: S3 stops mid-job

Posted: Sat Feb 06, 2016 11:59 pm
by 461oceanblvd
Not sure if you meant to respond to me, but I linked the cable I used in the previous post, and plugged it into the 1x6 pin connector in the bottom middle seen here: