Page 4 of 20

Re: S3 stops mid-job

Posted: Sat Aug 15, 2015 4:56 am
by apspurgeon
Hi all

So, I ran hours and hours of successful laser etching - no problem at all.

With the machine all set up, carbide ready with project loaded and all zero'ed, as soon as I turn on the router the computer lost connection to ShapeOko control board.
- pretty sure this proves electrical noise from the router (at least in my case) in causing the problem. The router is a Makita 0700C.

Given this, I have used Aluminium tape to shield the top of the control board 'case' (see pictures), the USB cable and Y stepper cables are taped against the frame with the same aluminium tape (trying to stop these acting as an Ariel)

Also, and importantly, non of the rails or base steel frame are electrically connected. I've run a wire from the X, Y and Z frames to connect them all together and then run this to earth. Now all the metal is earthed, and at the same electrical state, and as much as I can easily do, I have shielded the electronics (I have not run tape underneath control board 'case' yet (want to keep open for ventilation).

I've run a few jobs and and so far, so good...time will tell I guess. ... 0683665800

Re: S3 stops mid-job

Posted: Wed Aug 26, 2015 9:44 am
by apspurgeon
While better with the shielding and grounding I'm still having the same problem and notably 'air' jobs stop intermittently when our garage door opens. Clearly electrical interference but I have been unable to shield or ground it out.

Re: S3 stops mid-job

Posted: Wed Aug 26, 2015 10:40 am
by WillAdams
You have been careful in all this to ensure that you are not creating ground loops?

I added the metallic tape to my machine covering the inside of the enclosure top and it seems to have made a big improvement.


Re: S3 stops mid-job

Posted: Wed Aug 26, 2015 1:11 pm
Will, can you explain the concern for creating ground loops? I believe the CM board is isolated from the mounting locations. I haven't ohmed out all of the pins of the stepper motors to see if the ground loads are isolated from the casing.

Regarding the foil tape, have you checked continuity between the tape and case? Do you need to ground the tape or is the adhesive enough to conduct ground shielding?

Re: S3 stops mid-job

Posted: Wed Aug 26, 2015 1:31 pm
by WillAdams
AIUI, ground loops are created when one has multiple paths to get to ground. The ideal arrangement for grounding is a star topology, where from any given component which is grounded, there's only one possible path to get to the ground connection.

Ground loops were described as creating hard-to-diagnose errors, and it's simply good electrical practice (AIUI) to avoid them.

I actually consciously taped the metallic tape over w/ electrical tape so as to keep it electrically isolated. I suspect it might be connecting to the aluminum enclosure, but if so, not because I tried to make that connection. I would be glad to know whether this should be electrically connected to the balance of the enclosure. In retrospect, I suspect it should be.

Re: S3 stops mid-job

Posted: Wed Aug 26, 2015 1:55 pm
Thanks for the explanation Will. For shielding you want all of your shields at the same potential and tied back to earth ground.

If everything were tagged back to one common point of ground, I think there would be little chance for creation of a ground loop.

I believe the only item on the SO3 which is connected to earth ground is the power supply, which the 24vdc GND is isolated from chassis ground.

Re: S3 stops mid-job - SOLVED?!

Posted: Thu Aug 27, 2015 7:41 am
by apspurgeon
OK, I think I have this solved (finally)

After shielding the crap out of everything (including the entire length of the USB cable), connecting and grounding X, Y and Z metal pieces by co-incidence my wife came home....the garage door opened and the SO3 stopped. Now I had a reasonably reliable way to 'cause' the problem.

My SO3 is driven by a laptop, after testing the problem never occurred while running of just batteries. There was clearly a grounding/earthing issue associated with noise and the AC power for the laptop. Importantly the AC power for the laptop does not have an earth, it's just phase/neutral lines.

Root cause
So what is happening? Electrical noise generated by the garage door opener is inducing noise in the laptop AC cable (acting as an aerial) this high frequency noise wants to be grounded....and ground is only available through the USB cable to the ShapeOko and importantly through the ShapeOko electronics. This is a very bad thing!

The simple test was to ground the laptop, then any noise would not go through the USB to ShapeOko to ground. After putting a crocodile clip on the previously grounded ShapeOko metal, and the other on metal case of the laptop (now the laptop it'self is grounded, and not via the USB cable).

After 20 tests of the garage problem....after I disconnected the laptop ground (did this on video - now on youtube) it failed 1st time. Hopefully this answers it. So ground your PC/Laptop and ground the ShapeOko. Phew....


Re: S3 stops mid-job

Posted: Thu Aug 27, 2015 2:23 pm
by cvoinescu
You're lucky. The same change fixed it for me only about four times out of five (from every single time the fridge compressor stopped, down to crapping out only 20% of the time).

Re: S3 stops mid-job

Posted: Thu Aug 27, 2015 7:57 pm
by apspurgeon
I would recommend that all metal on the SO3 is connected and grounded (so all metal is at the same level, and ground is not just through the SO3 power supply) and that the compute device also has the same ground. I'll admit it is a problem, the SO3 should have better grounding, the electronics is not grounded to the metal frame which is a problem

Re: S3 stops mid-job

Posted: Thu Aug 27, 2015 8:27 pm
by CastIrony
Is there a danger of getting a ground loop that way?