Page 9 of 20

Re: S3 stops mid-job

Posted: Wed Jan 13, 2016 3:29 am
by Fablicator
KAScnc wrote:If someone else could give this a try, I'd appreciate it. I'm on the Stepoko controller having the same disconnect issue as the Carbide controller.

I'm able to reproduce the controller lockup 100% of the time by cycling the Dewalt DW611 router on and off multiple times at max speed. Doesn't matter what outlet or circuit being used.

I removed the DW611 from the spindle mount and tried the same thing. I couldn't get it to lock up at all when it wasn't attached, over 20 mins of cycling the power switch. Even held directly over the controller with no issues at all.

So far I'm not having the disconnecting issue with one layer of Kapton tape around the router to insulate it from the clamp. Just need to make sure no metal from the router is touching the spindle clamp.

While the SO3 was air printing I removed the router and Kaptons tape and mounted it back in the clamp. Within 30 seconds I was able to shut it down again by power cycling. I wont know about long term results till I cut something tomorrow.

Just curious if this will work for others.


I wonder if removing the SO3 electronics from the frame would have the same effect.

Re: S3 stops mid-job

Posted: Wed Jan 13, 2016 9:11 pm
by JeromyReno
has anyone else had a chance to try isolating the router from the machine yet. im thinking about putting my carbide board back on. I was changing my machine over to a tinyG hoping it would get rid of the problem with disconnects. mine has gotten worse with time. I tried to run the last part I was making 6 times and it stopped at different points on each run, and before I got my homing switches set up I ruined well over $100 worth of materials on marts I was making.. I had a tinyG from another machine I started building like 2 years ago (I got the shapeoko to make parts for this other machine haha skynet) and started retro fitting it.

but if de coupling the router and isolating the board can fix the problem it sure beats tossing this carbide board.


im waiting on another power supply to run it but I might throw the carbide board back on today and run it with everything decoupled and isolated just to see, cause I have time and will be to lazy if I get the supply and start running with the tinyg

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 12:11 am
by jfdotcom
That is a VERY interesting thing about insulating the router and it leads to me to speculate that all this time perhaps we're pointing the finger in the wrong direction.

I'd love to have a way to test this out with maybe 4 other DeWalt routers or at least a different router (my only other palm router is an older DeWalt that isn't of the "canister" shape).

Does anyone know of an instance of disconnect using a different brand of router?

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 12:34 am
by WillAdams
Yes. I’ve had disconnects w/ my Makita when shutting it off after a cut.

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 2:26 am
by JeromyReno
I put the carbide 3d board back in. insulated the router with kapton tape. also insulated the mounting plate for the board when reinstalling it with kapton tape and plastic washers.. still resets when cycled on and off. i'll try adding some grounds to see if that does anything productive ....

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 4:10 am
by edwan
After a initial issue with the USB I purchased a USB idolator form Saelig (details in the forum). I have never had a job stop or get disconnected since.
I was a little pricey, but in the end it was wort it. Other people have had good results with it.

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 4:27 am
by jfdotcom
I've had disconnects using the USB isolator so it's not a cure-all.

I'm grounding my machine in a few days to see how that does in addition to the isolator and a V2.1 board.

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 11:25 am
by KAScnc
Unfortunately it appears my router isolation with Kapton tape doesn't work. My cut stalled with 3min to go on a 4 hour run.

This is pretty frustrating in regards to not having one successful cut yet,

Re: S3 stops mid-job

Posted: Thu Jan 14, 2016 2:25 pm
I've taken a number of steps and nearly eliminated drops on my SO3. I am aware of what causes USB drops in my configuration and take steps to avoid triggering a USB drop when I am operating the SO3.

Steps I've taken include isolating the AC power cord for the router, Ferrite cores, galvanic isolator, separate desktop computer, grounding braid to all metal components back to the power supply chassis, and dust collection hose with grounded metal coil.

I am currently experiencing USB communication drops two ways. When I leave the room, return and touch anything electrical plugged into the same circuit which does not have a ground plug or the router body, main culprit is touching the laptop I have V-Carve on , if I touch the Shapeoko power supply chassis to discharge static I don't get a drop(I have the first version with metal chassis). If my dust collector drum gets over 3/4 full I notice an occasional disconnect at the end of the job, but these are rare.

I'll try a static mat next and wrist strap if I feel the need, but for now the drops are minimal and I am aware what causes them for my configuration . Running the machine a minimum of 4 hours a day over the past two months, I've experienced only 4 USB drops, all of which I was able to recover from. I also have Hall effect limit switches and use WCS.

Re: S3 stops mid-job

Posted: Fri Jan 15, 2016 8:07 pm
by Neppo1345
I've seen a large decrease in disconnects after grounding my router. I expect I would see even further improvement if I ran copper braid from the router to the gantry, and again from the gantry to the frame.

I took a 3-wire power cable from an old desktop PC and connected it in place of the stock power cord of the router, and tied the ground pin to the case of the router.

I have some pictures of the mod I can post up once I get home from work if anyone has any interest.