Page 1 of 1

Dual y axis not in sync

Posted: Sat Mar 30, 2019 1:56 am
by kaka
Hello everyone
I'm assembling a 1500 x 1000 eshapeoko from catelins store. Everything seems to be working ok except when I run the 'hello world' task. My machine writes the s and h perfectly but has problems with all the letters after that. If I run the whole script it looks like sometimes only one of the y motors moves and drags the other, even tho they should be doing the same thing. Has anyone else experienced this? I'm running a protoneer v3 shield with 4 pololu drv8825 drivers, and the grbl 0.8 code. I've tried several things, tightening the gt2 belts, and slowing the feed rates right down to no avail. I could try wiring both y motors to one driver, or messing with the pots on the drivers (currently I haven't touched the driver pots, they are stock out the box), what do you guys recommend? Like I say the S and H draw perfectly, and i can draw a 300mm x 100mm square quite easily so my machine is relatively close to working accurately. Any help would be greatly appreciated.