Page 3 of 8

Re: will1384's Shapeoko 2

Posted: Sat Jan 25, 2014 2:12 pm
by chomdh
Will1384 - loving all the pics of your shop and shapeoko accessory builds. Can't wait to see what you do when the shapeoko is assembled and operational.

I need to read up on limit switches.

Re: will1384's Shapeoko 2

Posted: Sun Jan 26, 2014 2:40 am
by will1384
chomdh wrote:Will1384 - loving all the pics of your shop and shapeoko accessory builds. Can't wait to see what you do when the shapeoko is assembled and operational.

I need to read up on limit switches.
Thanks


Part (3) assembly.

This is all I got done today

Image

I did run into a problem, on this page

http://docs.shapeoko.com/carriages.html

it says "Use four M3x6mm SHCS to attach each stepper motor" but on this page

http://blog.inventables.com/2013/10/sha ... order.html

the only M3 hardware listed thats absent from the mechanical kit, is this

M3 Hex Nuts Qty 8
M3 Flat Washer Qty 35
Socket Head Screw M3 x 12 Qty 8
Socket Head Screw M3 x 8 Qty 12

but the M3 8mm Socket Head Screw worked just fine using only one M3 washer, I got lucky and ordered extra.

Re: will1384's Shapeoko 2

Posted: Sun Jan 26, 2014 9:33 am
by bmsleight
I also had not M3x6mm SHCS in the full kit. I also used M3x8mm SHCS. I think the instructions need updating.

Re: will1384's Shapeoko 2

Posted: Sun Jan 26, 2014 1:01 pm
by WillAdams
Thanks. That's a fungible aspect. AIUI the thread depth on the motors varies w/ each lot, so the screw length is matched to the current lot. I've edited the instructions to reflect that.

Re: will1384's Shapeoko 2

Posted: Mon Jan 27, 2014 2:17 am
by will1384
Part (3) assembly, continued.

This is what I did today :D

Image

I also updated the software on the computer I was going to use, installed a Active USB Extender, powered USB hub, and power cable for the CNC controller box, all because the computer is inconveniently located LOL, and all attached to a uninterruptible power supply / UPS.


I was missing some more screws, I was short two M5 x 10mm BHCS, listed on this page

http://docs.shapeoko.com/workarea.html

in the "Assemble the Frame" section, I was only short two screws, so I might have lost them or used them in another place, but I had got extra so it worked out.

I measured and cut all my belts to 54 centimeters or just about 21-1/4 inch, seemed to work perfect at that length, I started with a 6 foot section and had a little less than 1 foot left over.

I wondered how to lift both rails up so that they would be level, when working on the "Assemble the Frame" section, and I have lots of socket sets and just happen to have two sockets the same diameter, and they pushed the rails up as far as they could go, I then tightened the bolts.

I did make a small change to my Shapeoko 2, on this page:

http://docs.shapeoko.com/gantry.html

under "Sub Gantry" and "Complete Gantry" I substituted "M5 x 16mm BHCS" for the "M5 x 12mm BHCS" listed.

Re: will1384's Shapeoko 2

Posted: Mon Jan 27, 2014 9:58 pm
by will1384
Part (4) wiring.

I spent a few hours today trying to figure out how the current limit is set on the grblShield, one way is to just "tune it in"
I did that on my last CNC router, it worked but I never liked doing that.

Here is the page on that.

https://github.com/synthetos/grblShield ... grblShield

So I downloaded a few PDF files:

This the the PDF on the DRV8818

http://www.ti.com/lit/gpn/drv8818

and here for the grblShield schematic

https://github.com/synthetos/grblShield ... _schematic

From what I can see you need the know the VREF, and from the grblShield schematic it looks like the VREF goes directly to (pin 2) of the potentiometers.

When reading the DRV8818 PDF, it gives you this example, using a (0.22 Ohm) resistor, and a VREF pin showing (3.3v)

8 x 0.22 = 1.76


3.3 / 1.76 = 1.875 Amps

And grblShield uses the DRV8818 chip and (0.1 Ohm) resistors, so calculating the voltage should be

8 x 0.1 = 0.8


now use the (0.8) with the VREF voltage, lets say you measured (1.5v) with the volt meter

1.5 / 0.8 = 1.875 Amps


I made up an image to help me

Image

I got my NEMA17 motors from inventables, and the page here:

https://www.inventables.com/technologie ... or-nema-17

shows "Current / Phase 1.68 A"

so I think I would need 1.3v on VREF

1.3 / 0.8 = 1.625


Is this correct?

I am going to finish wiring up the stepper motors and testing the CNC control box tonight, lets hope I don't let the smoke out of it :shock: LOL

Re: will1384's Shapeoko 2

Posted: Tue Jan 28, 2014 4:19 am
by will1384
I got most of the wiring done, and checked all the wiring for problems with a volt meter, everything looked good, hooked everything up and and turned on the CNC control box, the indicator light was lit, the power supply's green led is on, the Arduino UNO's green led was lit so it was was getting power from USB, but nothing was lit on the grblShield, also my 24v fan was not working, I checked the E-Stop, it was not the problem, my 24v power supply is not putting out anything on the positive side.

I am going to look over the power supply tomorrow, I recycled it from my old CNC router, and it was working, so I am not sure what happened, I had got two power supplies years ago just for stuff like this, so I have a replacement unit thankfully.

Re: will1384's Shapeoko 2

Posted: Tue Jan 28, 2014 7:30 pm
by will1384
will1384 wrote:I got most of the wiring done, and checked all the wiring for problems with a volt meter, everything looked good, hooked everything up and and turned on the CNC control box, the indicator light was lit, the power supply's green led is on, the Arduino UNO's green led was lit so it was was getting power from USB, but nothing was lit on the grblShield, also my 24v fan was not working, I checked the E-Stop, it was not the problem, my 24v power supply is not putting out anything on the positive side.

I am going to look over the power supply tomorrow, I recycled it from my old CNC router, and it was working, so I am not sure what happened, I had got two power supplies years ago just for stuff like this, so I have a replacement unit thankfully.

The power supply is OK, I just messed up on the wiring, I should have had the gShield (GND) going to (-V), everything is working now, I also had the fan wired in the same way, so it was not working, now the fan (Red) wire goes to (+V) and the fan (Black) wire goes to (-V).

I also changed the wiring diagram in my earlier post.

Re: will1384's Shapeoko 2

Posted: Wed Jan 29, 2014 3:49 am
by will1384
Part (5) fine tuning and adjusting.

I had to make a pen holder, it worked but not that good, I used some pipe, a spring, two rubber grommets and tape, along with a sharpie, the pen holder had two much play and pressed the pen down to hard, I guess my next step is to make a better pen holder, this is as far as I got today.

Image

I was able to to find (VREF) on (pin 2) of the potentiometers, and adjusted the potentiometers to 1.4v or 1.75 Amps, it seemed to work at that setting and the stepper motors never got warm, I am thinking about adjusting the Y-Axis potentiometer higher because it drives two motors.

Re: will1384's Shapeoko 2

Posted: Sun Feb 02, 2014 5:33 am
by will1384
I decided to use some 1/4-20 T-Nuts on my Spoilboard and used a drill press, speed square, pencil and rubber mallet to install, simple quick and easy.

Image

Image

Its not perfect, and I should have placed more of the T-Nuts toward the center, and avoided the edge near the Y-Axis rails, I am likely to install more T-Nuts later.