Edward's S2 Buildlog (rebuild log)

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Edward's S2 Buildlog (rebuild log)

Post by cvoinescu » Tue Apr 22, 2014 10:38 am

Hey Edward, that Porter-Cable spindle looks sweet!

And you're right, in some cases prints suffer from layer adhesion problems. One or more of these might help:
  • Increase print temperature (even 5°C can make a big difference, but if you can increase it by 15-20°C, try it);
  • If you have a fan cooling the work, turn it down;
  • Print slower (yeah, I know, it's slow enough already, so this is a last resort);
  • Decrease layer height a little, so that they get squeezed together more.
Basically, you're looking for anything that helps the last printed layer melt a little as you print the next one on top of it, so that they bond together well.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

skipmcdonald
Posts: 22
Joined: Fri Oct 25, 2013 2:31 pm
Location: Dallas/Fort Worth Area, Texas, USA

Re: Edward's S2 Buildlog (rebuild log)

Post by skipmcdonald » Thu Apr 24, 2014 10:18 pm

That looks very nice. Your design is amazing and I am happy to contribute to the cause.

Please don't take the following as criticism in any way. Aesthetics are a very subjective and personal thing.

I didn't feel the need to have a 550mm bed because the 500mm of just the two extrusions covers everything between the makerslide rails.
Also I didn't want to give up two key anchor points. See the arrows pointing to the tapped screws in the image below.
Image

Those made a big difference in rigidness and squareness for mine. Plus you don't have to measure anything, it all just goes together by design.
I have also recently made "dog eared" versions of the little plate in the middle that don't block the t-tracks at all. Those old ones in the middle of the picture caused a minor problem inserting and removing some of my tiedowns. I am re-making them out of aluminum or steel stock next.

Another reason I didn't cover the whole 550mm bed is that I couldn't find any 15mm x 25mm extrusions, I also didn't find any 50mm that weren't 10mm thick. I didn't consider having two different heights on the bed.

I also upgraded to homing switches so the upper right area of the bed is my new critical spot to clamp down work / and or a fence tie down. The middle of the bed having a slightly wider flat between t-slots hasn't bothered me so far.

Last these printed do-hickeys are going into the two channels where the extrusions go together just because I think it's cool to handle them as one 500mmx500mm big piece.
https://www.thingiverse.com/thing:74301
They can be knocked into place so that all 4 are evenly space at about 100mm intervals with a 5mm rod.

Regarding printed mounts:
My printed Dewalt DWP611 mount is one piece and printed twice for upper and lower. It works fine printed in PLA flat on the bed. It was printed with only a 50% fill at 0.15mm layers. I am going to mill something stronger someday but this one is working well enough to snap a 1/8 in. endmill without breaking loose (my error). The only difficulty is that one must remove the z-axis plate in order to mount the Dewalt properly and then slide/roll the whole thing back onto the makerslide while turning the lead screw by hand.

Here is the Openscad source file for my mount, I'm sure it would be easy to adapt if your router's body diameter if it is different.
https://db.tt/tiEFW76r
the STL file is also in my build log if the router body is 2.75in diameter like my DeWalt.
Shapeoko 2 #3181, Protoneer Arduino CNC Shield, Step-Stick 4988s, GRBL 9b+, All Aluminum Bed - Misumi HFSQN4-15250 extrusions, Dewalt DW611, Precision Think & Thinker, Collets.

edwardrford
Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL
Contact:

Re: Edward's S2 Buildlog (rebuild log)

Post by edwardrford » Fri Apr 25, 2014 4:29 am

Skip - Thanks for the feedback!

First, what a great idea you had for using this misumi part as a table. it's really great stuff and fits nicely into the design. I've been trying to come up with a name for it that incoroporates your username, as a way of giving you credit. Something like The Skip Table, or the mcdonald, etc.

I didn't even realize that the holes from the table extrusion matched up with the holes on the end plates! That was pure coincidence, but it's cool that it worked out that way. I might have to go back redo mine. For the spacing left over on the sides, I might have some 12ga laser cut to fill the gaps. My main reason for wanting to fill the whole space is because I'm working on an enclosure for the machine, and don't want little bits (or noise) seaping out from the bottom.

The plugs look pretty promising as well. I'll print out a few of those and pound them in. As is, one of my extrusions is *slightly* higher than the other (by less than .25mm) but I can feel it when I run my finger over. If I put a piece of extrusion across (to check for flatness), it's about +1mm above the surface on the far side (roughly 250mm from center). It might just be one of my brackets, but I haven't done much investigating.

As for you front bracket, I've been thinking of getting one laser cut to fit the gap between the end plates, with a hole pattern that matches the extrusions, and holes on the bottom to bolt it to the front extrusion. There would be slots cut out to allow for t-nuts to slide in and out. If there's enough interest, brandon could stock them in the store for a pretty reasonable price.

I'll drop your stuff into openSCAD and generate an STL. I think the Porter Cable and the DW611 are the same units (basically) and should be able to share a mount. So, thanks for posting that.

-Edward
Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

skipmcdonald
Posts: 22
Joined: Fri Oct 25, 2013 2:31 pm
Location: Dallas/Fort Worth Area, Texas, USA

Re: Edward's S2 Buildlog (rebuild log)

Post by skipmcdonald » Fri Apr 25, 2014 7:37 pm

Edward - thank you so much for your wonderful creations and ideas!

I would be very interested in a laser cut steel precision bracket. If we linked up 4 (15250) extrusion holes in the new bracket instead of just 2 it might take out the c-clamp and flat edge assembly steps I used to make sure the two pieces were flat and square in the middle and at both ends while tightening everything down.
I can supply a DXF after I test the print it to verify it fits.
Image

Here are the assembly steps I used below.

For the clamping jig I used a wooden spoilboard on top (lengthwise going back to front), The clamps all had rubber jaws so I could clamp to the 2020 directly.
1. I installed all the screws through the existing stock Shapeoko 2 endplates simi-tight and the ones into the tapped 12500 holes and tapped makerslide completely tight at both ends of the Shapeoko.
2. I installed the jig and clamped the spoilboard down loosely at first at both ends and added clamps at the corners of the bed nearest me. Hanging the Shapeoko off the worktable by about 3 to 5 inches helped me install the clamps easily. The table edge allowed the bed to just lay flat. The tilt caused by the 2020 and clamp at the back wasn't a concern.
3. I adjusted the two extrusions by feel, tightened the jig a little more but not completely.
4. I installed the small printed plate, installed the bottom screws into the t-nuts hand tight and tightened the two top screws completely tight. This squared up the bed (in the XY plane) and the second time through the whole Shapeoko sort of snapped into alignment probably overcoming the tension in some hand tight screws.
5. I tightened the clamping jig pretty tight checking for gaps between the 12250 and the 2020 util they were gone. This fixed the z plane
6. Then I tightened all the screws that went into the 2020 T-nuts in both end brackets and the middle brackets.
7. I removed the corner clamps and I turned the Shapeoko around and repeated 2-6 again.
8. I then removed the jig. Checked things with a square, no adjustments needed.
That let me take all the "slack/twist" out of the t-nuts/fasteners/brackets and left a very level bed and a very Squarely aligned Shapeoko 2.

Considering the closed bed you need, you might be able to use a 3 series 15mm x 15mm on one side and the same 15mm x 15mm along with a 15mm x 20mm one on the other?
I don't know why I seem to have a 15mm obsession, something thicker or thinner would probably work just as well.
2 x HFS3-1515-500
1 x HFSQN4-1520-500
The problems I see are:
1. attaching the 1520 since it only has side channels and no slots top/bottom but perhaps the do-hickeys would be enough?
2. The slots on standard series 3 are only 3.4 mm so you have to use M3 bolts and tiny T-nuts.


Putting the Shapeoko 2 in an enclosure is a great idea. I may do it myself but I would have to design it to still be able to easily remove the end panels so that I can continue to do composite mills of one long workpiece against a fixed fence for sign making, furniture, etc. I have done 2 and 4 foot long workpieces already. Your open ends design of the Shapeoko 2 bed made that kind of work possible and it isn't that hard to mark and move the piece very precisely one foot at a time against a marked fence. Repeatability was easy with the homing switches, but a light tool mark demple on the fence worked fine before I upgraded to homing switches. I still have to manually jog the Z origin of the workpiece into place.

I am thinking about an enclosure design using "trapped" panels in stock series 5 or series 3 extrusions. Could a 550mm x 472mm x 6mm panel slid into the existing 2020's slots add a bottom to the enclosure and eliminate the need to make a 550mm bed? I suppose it would probably collect a lot of debris over time.


My first approach to the table was almost exactly like yours, I even fabricated a bunch of printed brackets with slot filling tabs but when the stock plate hole pattern lined up I had an "AH HA!" moment and abandoned them to my scrap pile of printed plastic.

Here are some png renders of the brackets exported out of Openscad just for history sake. They were printed in PLA with 1mm thick top, bottom, and walls and infilled at only 25% between. Then I used a steel file to clean them up and ensure a tight fit.


Image
15x20x20 to bolt the 15250 edge to the 2020 rail. The screw heads barely clear each other so you have to drop in both screws first and then tighten both at the same time, working the part into place using the little play you do have.

Image
A 20x20x20 to use under the bed just like your angle ones. It is also designed to fit the END of the 2020, like and end cap but attach 2 pieces at right angles. A 3 sided or 14mm offset one might be useful in fabricating a 2020 based enclosure. Perhaps I'll design and print some.

For causal readers: WARNING I ABANDONED THE FOLLOWING BEFORE TESTING THEM..
I also designed but didn't fabricate these double hole brackets:
Image
These would work in the middle to join two plates.
Image
These are for anywhere except the middle.


Skip
Shapeoko 2 #3181, Protoneer Arduino CNC Shield, Step-Stick 4988s, GRBL 9b+, All Aluminum Bed - Misumi HFSQN4-15250 extrusions, Dewalt DW611, Precision Think & Thinker, Collets.

edwardrford
Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL
Contact:

Re: Edward's S2 Buildlog (rebuild log)

Post by edwardrford » Sat Apr 26, 2014 9:14 pm

Great info Skip! You are much more meticulous than I, and that is something that I envy. I basically just lined up the edges and then clamped everything down as tight as I could!

Let me know after you've verified the front bracket design. I'll get a few cut and painted for us and we can test them out. I was thinking of going wider (like the entire width!) but can see how a more modular approach would be beneficial.

Last night I got back to work on my machine. First thing I did was get my Up Mini Setup to print out Skip's DW611 brackets.
3d_setup.jpg
3d_setup.jpg (182.84 KiB) Viewed 2232 times
That process went pretty well, aside from my not calibrating the bed height for a different pc. This resulted in a really compressed raft that was nothing short of a bitch to get off.
smashed_raft.jpg
smashed_raft.jpg (91.78 KiB) Viewed 2232 times
But all turned out well in the end and the brackets worked a treat:
bracket_printed.jpg
bracket_printed.jpg (86.68 KiB) Viewed 2232 times
brackets_mounted.jpg
brackets_mounted.jpg (96.21 KiB) Viewed 2232 times
A few days ago I decided to go a different direction with the controls on this one and swap out the arduino + grbl setup for a mach3 config. I am now the proud owner of 2 Shapeoko 2 machines so I feel like I have some leeway with this unit, and can use the other as a stock machine if needed.
new_addition.jpg
new_addition.jpg (165.82 KiB) Viewed 2232 times
Within my personal CNC circle, there's been a lot of mach3 talk lately, and despite my dislike for it (mainly because of how ugly and 'overcomplicated' the screens are, among other things), I decided that I should stop hating and just consider it another viable option. I have experience using the program because that's what runs the Little Machine Shop Mill I have in my shop, and it's what I used for the custom GE garage machine I built last fall (at their request).

To get around the whole parallel port thing, I decided to go with a UC100 usb controller. It's a nifty little $130 dongle that has DB25 on one side, and usb on the other. This let's me run mach3 from my macbook (running windows via bootcamp). The UC100 only works with mach3, and requires an included plugin to operate correctly. I did notice that between last fall and now, they updated their drivers to be WHQL compliant, which was a pleasant surprise.

For the driver I went with the TB6560, 4 axis board that comes in the aluminum enclosure. I bought this from ebay for about $60 delivered.

Soup to nuts, running your machine with this setup will cost you roughly $350 more than with the arduino setup once you account for the $175 mach3 license.

Here's a shot of the area I was doing the work in about midway through the conversion. You can see the UC100 in the baggie (it's pretty small) and the TB6560 sitting on top of the power supply.
work_zone.jpg
work_zone.jpg (162.67 KiB) Viewed 2232 times

While the brackets were printing (each one took about 45 minutes) I went about disassembling my arduino and gshield setup and doing the wiring into the TB6560.

Once the prints were done, and the 450 mounted, I setup the mach3 ports and pins section along with the motor tuning. I should post that information to the wiki for future reference because it took me about an hour to get it running right. The TB6560 documentation is terrible, so the first 3 datasheets that I found had the incorrect (and all different) pinouts. Plus, I wasn't sure what the microstepping was set to, so I had to do some experimenting to figure out the default (for all axis) are set to 8x.

This was almost my first chance to test out the new z-axis design that Brandon and I have been working on. You'll notice that I ordered the wrong length belting (too long), so I needed to put that idler in to take up some of the slack. If the belt were the correct length, the idler isn't necessary because the mounting holes for the motors are slotted to allow for 5mm of tensioning. But, when it comes to prototypes, it's important to get them to 'just work' so you can identify any other flaws in the design before doing another revision. Seems like everything except the belt length was correct on this one. I'll start another thread with more info if anyone is interested.
testing_out_zaxis.jpg
testing_out_zaxis.jpg (143.43 KiB) Viewed 2232 times
I've pretty much used up all of my project time for the weekend, so no more work will get done until later next week. Once that time comes around I'll start putting the enclosure on.

-Edward
Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

skipmcdonald
Posts: 22
Joined: Fri Oct 25, 2013 2:31 pm
Location: Dallas/Fort Worth Area, Texas, USA

Re: Edward's S2 Buildlog (rebuild log)

Post by skipmcdonald » Sat Apr 26, 2014 10:11 pm

I like that Z axis design. I tried making a similar one with herringbone printed gears, it required 3 gears but I'm not satisfied with it yet. A belt is the way to go.

I also posted the New bracket files over in my buildlog. It's lucky I tested it, the spec on the Misumi site is misleading or something. It shows the lower hole as 4.5 mm above the extrusion base. It won't fit that way though, I drove myself crazy trying to fit it. I finally just eyed it and printed one with 5mm that worked fine for my test fit. I also made the bracket 34.5 mm just to allow clearance top and bottom. All the other dimensions are spec.

I'm thinking about milling a couple out if some scrap aluminum angles using my Shapeoko 2 but I want to resolve what the actual dimensions are for that hole first!
Shapeoko 2 #3181, Protoneer Arduino CNC Shield, Step-Stick 4988s, GRBL 9b+, All Aluminum Bed - Misumi HFSQN4-15250 extrusions, Dewalt DW611, Precision Think & Thinker, Collets.

crazeegeek
Posts: 118
Joined: Thu Mar 13, 2014 9:37 pm

Re: Edward's S2 Buildlog (rebuild log)

Post by crazeegeek » Sun Apr 27, 2014 1:35 am

edwardrford wrote: This was almost my first chance to test out the new z-axis design that Brandon and I have been working on. You'll notice that I ordered the wrong length belting (too long), so I needed to put that idler in to take up some of the slack. If the belt were the correct length, the idler isn't necessary because the mounting holes for the motors are slotted to allow for 5mm of tensioning. But, when it comes to prototypes, it's important to get them to 'just work' so you can identify any other flaws in the design before doing another revision. Seems like everything except the belt length was correct on this one. I'll start another thread with more info if anyone is interested.
testing_out_zaxis.jpg
-Edward
That z axis looks great.

Is this something you intend to offer for sale later and does this setup help with the weight distribution over the rails? What is the clearance of the stepper motor from the carriage assembly in this setup? I run mine with NEMA 23 stepper covers, which pushes the stepper body length out to 73mm.

RobCee
Posts: 587
Joined: Wed Jan 08, 2014 11:33 am
Location: Birmingham, UK

Re: Edward's S2 Buildlog (rebuild log)

Post by RobCee » Sun Apr 27, 2014 9:49 am

That inverted Z-Axis looks awfully familiar Edward; nice job on getting to it first though!
I have been stalling for time since looking at my version of that design, since I have had the machine in so many bits for way too long...
Once I get mine up and running it would be interesting to compare notes and see if we can improve anything.
ShapeOko2 #3400 - Chinese 800W AC Spindle - Stiffened X-Axis - TR10 Z-Axis - Inverted Z Motor - Hall Effect Limits - Drag Chains & Custom Brackets

edwardrford
Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL
Contact:

Re: Edward's S2 Buildlog (rebuild log)

Post by edwardrford » Sun Apr 27, 2014 1:38 pm

Thanks Rob, is there a picture of yours somewhere?

This Z-axis design has been in the works for a little over a year, here's a picture of the very first one (march, 2013):
Image

The side mounted design had some flaws, and didn't accommodate nema23. This newer one (rev3) seems spot on. We need to finish up testing, but it should be available soon through the shop.

Regarding motor sizes and orientation:
Yes, it will take a nema23, but you will probably need to mount it on the top of the plate, instead of upside down like the nema17. There are only a few mm to spare with the stock nema17 upside down. I tried making the hole for the motor boss large enough for nema23, but it's too large and ended up devouring the mounting holes for the nema17s.

-Edward
Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

RobCee
Posts: 587
Joined: Wed Jan 08, 2014 11:33 am
Location: Birmingham, UK

Re: Edward's S2 Buildlog (rebuild log)

Post by RobCee » Mon Apr 28, 2014 1:55 pm

Interesting side mounting idea Edward! I like the idea of trying to use up some of the dead space alongside the Z-Axis.
My design only got as far as some 2D drawings to date. I needed to try to move my spindle closer to the gantry, as it is a hefty Chinese air cooled 800W one.
The ideas I had are shown here and I will be getting round to cutting the preliminary design from a chunk of Aluminium in the next few weeks.
I wanted to reduce the offset between the spindle and the mounting plate from ~20mm to ~7mm as the twisting forces of a 2.4kg unit are not good!

I have just flattened my base again and am ready to test the spindle by chomping on some acrylic to make a dust shoe. Fingers crossed!
ShapeOko2 #3400 - Chinese 800W AC Spindle - Stiffened X-Axis - TR10 Z-Axis - Inverted Z Motor - Hall Effect Limits - Drag Chains & Custom Brackets

Post Reply