Trouble adjust cutting speed

Post Reply
ColeHolloway
Posts: 7
Joined: Tue Jul 09, 2013 7:17 am

Trouble adjust cutting speed

Post by ColeHolloway » Wed Jul 16, 2014 12:14 am

Hi everyone.

I am trying to cut some soft plastic with my shapeoko, and the speed of the shapeoko when cutting is going far to fast to make a accurate cut. I have successfully adjusted the default seek and feed of the shapeoko by manually changing the F, $4, and $5, but this only affects the speed of the machine when it is traveling to the next cut point, not the speed of the shapeoko when it cuts.

I am using the universal g-code sender with a macbook pro. Does anyone know how I can change this setting?

Thanks!

WillAdams
Posts: 8489
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Trouble adjust cutting speed

Post by WillAdams » Wed Jul 16, 2014 12:53 am

The feed rate is adjusted in your CAM tool --- what did you use?

See http://www.shapeoko.com/wiki/index.php/CAM for more options.

More information at http://www.shapeoko.com/wiki/index.php/Endmills and http://www.shapeoko.com/wiki/index.php/ ... s#Plastics
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)

ColeHolloway
Posts: 7
Joined: Tue Jul 09, 2013 7:17 am

Re: Trouble adjust cutting speed

Post by ColeHolloway » Wed Jul 16, 2014 2:25 am

I make the G-code in cambam, and then export it using the universal G-code sender (http://www.shapeoko.com/wiki/index.php/ ... ode-Sender) It seems like the 3 settings for feed rate, F, $4, and $5 only change the speed of the shapeoko when it moves from cutting point to cutting point, the speed changes to a constant rate whenever it begins to cut. Is the cutting feed rate adjusted in the gcode?

Auarhau
Posts: 243
Joined: Tue Feb 25, 2014 8:46 pm

Re: Trouble adjust cutting speed

Post by Auarhau » Wed Jul 16, 2014 7:28 am

Yes, the feed rate (cut speed) is defined in the G-code, which means you have to set this value in CamBam. Probably you are using a default feed rate value in CamBam which is way too high. Open up your code and look at the value behind F. Like this: G1 Z-1.0000 F125.0 means this cut will move -1mm in the Z direction at 125mm/min. Check out the feeds and speed section of the wiki to get an idea of what settings you should use for your material.

The seek speed you set in grbl is as you have figured out already, the speed at which the machine moves between points when not cutting. There is also a default feed rate parameter in the grbl configuration ($4 I believe for Grbl 0.8), as you have discovered. Don’t mind this setting really. Leave it at the wiki default of 500. This setting only comes in to play if your G-code has no feed rate defined. And your G-code should always have a defined feed rate for every operation, thus making the default grbl feed rate setting kind of useless.
ShapeOko 2. Nema 17 74 oz·in. GAUPS shield on Arduino Uno. DRV8825 Drivers x4 . Kress 1050 FME-1. Z Acme Screw. Threaded inserts table.

WillAdams
Posts: 8489
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Trouble adjust cutting speed

Post by WillAdams » Wed Jul 16, 2014 10:17 am

Grbl's default feed rate is not just useless, but downright anomalous, since other g-code interpreters don't define it.
Shapeoko 3XL #0006 w/Makita RT0701 Router w/0.125″ and ¼″ Elaire precision collets
Nomad 883 Pro #596 (bamboo)

fl0yd
Posts: 87
Joined: Wed Mar 12, 2014 5:37 pm
Location: St. Louis, MO

Re: Trouble adjust cutting speed

Post by fl0yd » Wed Jul 16, 2014 12:38 pm

WillAdams wrote:Grbl's default feed rate is not just useless, but downright anomalous, since other g-code interpreters don't define it.
It's also deprecated in v.9

Fl0yd

ColeHolloway
Posts: 7
Joined: Tue Jul 09, 2013 7:17 am

Re: Trouble adjust cutting speed

Post by ColeHolloway » Wed Jul 16, 2014 2:51 pm

Auarhau wrote:Yes, the feed rate (cut speed) is defined in the G-code, which means you have to set this value in CamBam. Probably you are using a default feed rate value in CamBam which is way too high. Open up your code and look at the value behind F. Like this: G1 Z-1.0000 F125.0 means this cut will move -1mm in the Z direction at 125mm/min. Check out the feeds and speed section of the wiki to get an idea of what settings you should use for your material.

The seek speed you set in grbl is as you have figured out already, the speed at which the machine moves between points when not cutting. There is also a default feed rate parameter in the grbl configuration ($4 I believe for Grbl 0.8), as you have discovered. Don’t mind this setting really. Leave it at the wiki default of 500. This setting only comes in to play if your G-code has no feed rate defined. And your G-code should always have a defined feed rate for every operation, thus making the default grbl feed rate setting kind of useless.
This solved my question! thanks Auarhau!

Post Reply