consistent zero

Post Reply
jdunne
Posts: 13
Joined: Mon Oct 13, 2014 10:48 pm

consistent zero

Post by jdunne » Thu Nov 13, 2014 12:48 am

Hello everybody

I am trying to use the same zero for multiple passes. I am using a variety of CAM product. Most recently Meshcam. And I find that I acually need to run more than one nc pass due to tool change or other reasons...

So using MeshCam and Unversal gcode sender,

I am able to get the zero to work predictably be power cycling the gblshield. and restarting UGS. I am manually positioning the zero.. great. Problem is after running the first nc file to completion the tool stop at the last point on the tool path.... Worse if I then use any of the UGS commands like z+ or go to zero the machine goes crazy and will crash into the upper z limit.... I have to pull the plug... WTF?

I would think I can run nc file after nc file, and the gblshield will remember where zero is?

this is the nc code I just sent... after running this successfully, my only option is to power cycle the glblshield then move back to original 0,0,0

it must be the code? is there a line somewhere screwing something up?
Attachments
1shoe mag cuts.zip
nc file that just ran, afterwards shapeoko 0,0,0 is kabloeey
(862 Bytes) Downloaded 61 times

WillAdams
Posts: 8604
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: consistent zero

Post by WillAdams » Thu Nov 13, 2014 1:37 am

I've always found it helpful to shut down the connection to GRBL after running a file --- one thing I've tried to do is to add a safe return to machine zero to the end of my files (and a welcome feature for G-code senders would be an option to do so after running a file).
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

FaVo
Posts: 13
Joined: Thu Oct 02, 2014 9:01 am

Re: consistent zero

Post by FaVo » Thu Nov 13, 2014 12:58 pm

I'm generating my g-code using jscut (http://jscut.org/) which has an Option to move back to zero after the job.

And ChiliPeppr is a great tool to send the g-code to grbl. Really nice page with 3D preview and all stuff you need. Works very well and has also function to reset zero or move back to zero anytime you want!
http://chilipeppr.com/grbl

jarretl
Posts: 135
Joined: Mon Feb 24, 2014 2:50 pm
Location: Edmonton, AB

Re: consistent zero

Post by jarretl » Thu Nov 13, 2014 3:24 pm

jdunne wrote: I am able to get the zero to work predictably be power cycling the gblshield. and restarting UGS. I am manually positioning the zero.. great. Problem is after running the first nc file to completion the tool stop at the last point on the tool path.... Worse if I then use any of the UGS commands like z+ or go to zero the machine goes crazy and will crash into the upper z limit.... I have to pull the plug... WTF?
You are setting your machine to inches mode in your .nc file (G20 command on line 3). At the end of your file execution, you need to manually send the G21 command to set back to metric mode before you use the jogging commands in UGS. You could also add G21 as the last line in your .nc files to set it back automatically once the program finishes running.
Shapeoko 2 #4043; DW660

twforeman
Posts: 1351
Joined: Tue Jan 29, 2013 4:51 pm
Location: Minneapolis, MN
Contact:

Re: consistent zero

Post by twforeman » Thu Nov 13, 2014 3:29 pm

jarretl wrote:
jdunne wrote: I am able to get the zero to work predictably be power cycling the gblshield. and restarting UGS. I am manually positioning the zero.. great. Problem is after running the first nc file to completion the tool stop at the last point on the tool path.... Worse if I then use any of the UGS commands like z+ or go to zero the machine goes crazy and will crash into the upper z limit.... I have to pull the plug... WTF?
You are setting your machine to inches mode in your .nc file (G20 command on line 3). At the end of your file execution, you need to manually send the G21 command to set back to metric mode before you use the jogging commands in UGS. You could also add G21 as the last line in your .nc files to set it back automatically once the program finishes running.
Or if you want to stay in inch mode when jogging, just use inch units. Set the jog unit to .1 instead of 1.

If you have limit switches installed you should read this about work coordinate systems and save yourself some trouble with setting zero: http://www.shapeoko.com/wiki/index.php/ ... te_Systems

You can also use any text editor to add commands to the end of your gcode file to send it somewhere (like: G0 X0 Y0 Z0)
Ender 3 3D Printer
ShapeOko v3 serial #0004 - upgrade thread
All of my ShapeOko related blog posts

jdunne
Posts: 13
Joined: Mon Oct 13, 2014 10:48 pm

Re: consistent zero

Post by jdunne » Thu Nov 13, 2014 8:45 pm

Awesume,

Thank for the answers guys. The english to metric totally makes sense.... I will address this. Also I just recieved my limit switches, and will be adding that to my build this weekend

Will Winder
Posts: 435
Joined: Fri Apr 20, 2012 2:40 pm
Location: Hudson, MA
Contact:

Re: consistent zero

Post by Will Winder » Sat Nov 15, 2014 10:02 pm

This is finally fixed in UGS, I made the changes today so now there are inch/mm radio buttons next to the jogging commands and UGS will change the active units if needed.
ShapeOko #367: Dual-Y drive, Belt on outside, 1000mm Y-Axis, DW660 Spindle, Nema-23 X/Y motors.

Primary developer on Universal Gcode Sender.

jdunne
Posts: 13
Joined: Mon Oct 13, 2014 10:48 pm

Re: consistent zero

Post by jdunne » Sun Nov 23, 2014 3:58 pm

nice

So the only remaining "issue" I seem to run into with UGS is large nc files. I have large nc files that are a combination of rough and several finish passes. I find one large nc file either seems to hang UGS when it loads... or it starts to send to the cnc, but UI becomes unresponsive... If however I break up the passes into separate smaller nc files. Then UGS seems to swallow each of these OK...

But so far, I have not gotten multiple passes to work perfectly due to not getting my zero consistent between runs...... I am going to hope that once I get my home switch setup. I can start to get reliable zero.....

Anyway if I could just use a single large nc file, it would solve my immediate issues... after 2 weeks of getting a little free time here and there to try things, i am still struggling to get a single part manufactured without some small issue...... Granted I am going true 3axis parts. I am purposely trying to machine very complex 3d geometry.... But that is the point. 2D carving works great.... MY goal is 3D sculpted, metal shapes.......

Thanks in advance

Joe

Herby53
Posts: 7
Joined: Sat May 03, 2014 8:21 pm

Re: consistent zero

Post by Herby53 » Mon Nov 24, 2014 5:57 pm

Hello,

one question to UGS. Is Version 1.0.8 suitable for TinyG V8?

I've read on github that this functionality will be added in the version 1.0.8.

Thanks

Herby

Post Reply