Page 1 of 1

pause between each line

Posted: Wed Nov 19, 2014 5:16 pm
by jdunne

I need to tap into your very helpful advice again. I have trying to figure out why some of my gcode seems to cause the grbl to pause at each line. Or at least that is what it looks like. I have created a multi pass toolpath. and I had thought that I tried to bump up the feedrate to 100in/min... I am just cutting foam to test the run....

Problem is the movements are verrrryyyy slow. and they actually look like they pause for each move... just the ramp of helix could take hours... it looks like it is still, but it is processing a line at a time very slowly. I dont get it... I have tried adjusting all the different parameters I can think of, I have tried several differing gcode senders.... Gcode simulations do not show slow speeds.... So I am stumped. I am sure is something obvious... and not all toolpaths have this behavior... Just the ones a crea about (:

is there something in UGS or chillipepper that I can adjust to fix this?

Re: pause between each line

Posted: Wed Nov 19, 2014 5:54 pm
by WillAdams
There's an option in some comm/control programs to pause and wait for OK after sending a line (or an option to not pause) --- you need to figure out which it is for your program and set it appropriately.

Re: pause between each line

Posted: Wed Nov 19, 2014 6:11 pm
by jarretl
Could you post your gcode file?
What program was your gcode created in?
Does the output log show any errors in the console early in the execution through UGS?
What grbl version are you using?

This is just a stab in the dark, but is it possible your gcode was generated for inches mode and your machine is still set to millimeter mode? In this scenario, movements of a fraction of an inch in your gcode would actually be trying to move your endmill fractions of a millimeter... So it would appear like a lot of tiny jittery movements of the endmill because it is trying to cut your path out at 1/25th of the size it should be...

Re: pause between each line

Posted: Thu Nov 20, 2014 1:02 am
by jdunne
(34.81 KiB) Downloaded 59 times

SOrry I thought I did post the gcode.. but I guess it was too big... I copy pasted just the first 1000 lines... it is a big file. But it starts off slow immediately

Re: pause between each line

Posted: Thu Nov 20, 2014 1:07 am
by jdunne

I am using HSMWorks.... Not all the HSMworks code is slow. I have done tests, where it runs very fast... which is the annoying part. I test, looks good. Then I create a real run. and I get this..

I have glbl .8c

I cant see any errors, since I can't see though since UGS is relatively unresponsive while I run it. At last on this big file.

Re: pause between each line

Posted: Thu Nov 20, 2014 4:01 pm
by jarretl
It looks like there's a pile of unsupported gcode in the first few lines (M26,M9,H0,G70, anything starting with a : will probably fail in grbl, etc).
The item of particular interest to you may be the G70 command, which according to an issue report here is the less standard equivalent of G20 (inches mode)

Grbl defaults to G21 (metric/millimeters) on startup, so when G70 fails to switch grbl to inches mode, you are seeing what I described in a previous post.
In this case, your first speed command is F60 (line 18), your machine is likely trying to move at 60mm/min, which is only ~2.4 inches/min - this would appear very slow as you indicated. :)
You should first replace the G70 command with G20 and try again.

Then you should try to find an export format for HSMWorks that more closely matches GRBL's requirements
I see on this page an experimental version of HSMworks from June 2014 added a specific grbl postprocessor (search the page for 'grbl post')
If you have an older version without a grbl specific gcode export, are you able to update or contact their support to see if you can test out the grbl post processor?
You may see more reliable results.

Re: pause between each line

Posted: Fri Nov 21, 2014 4:04 am
by jdunne
Thanks again

I have already been using the grbl post. So you would think it would take care of stuff like this...

I am going to take your advice on the G70 line... I will try this on the the same code and see what happens...

Also I wonder am I just committing some unforced errors by sending the code as inch. Its easy enough to switch to metric. Maybe I should just stick with metric for the post and see what happens....

I still kind of suspect the UGS. it really seems to become unresponsive. It is not showing which line is being sent. nothing it selectable. If the machine were not running I would think it was completely locked up... It seems to do this on large nc files... But Chilli pepper while it will load the bigger files, I have found after 6-7 it has crashed.... soooo ARRGGGG...

Anyway I will try a few of your helpful suggestions.

OK almost last question

TinyG. I have one.. Its on my todo list to install. I plan to upgrade to nema23 and tinyG. I wonder if tinyG is going to handle things more reliably? I have been waiting until I start to get good results on grbl.....