Problem with ramps and lead in Fusion.

aam
Posts: 38
Joined: Sat Aug 30, 2014 6:17 pm

Re: Problem with ramps and lead in Fusion.

Post by aam » Wed Feb 10, 2016 3:26 pm

Try the following:
Under the "Passes" Tab tick "Smoothing" and change the default value of 0.01mm to let's say 0.1mm.
This will generate a gcode file with much much less lines because the toolpaths are simplified with up to 0.1mm (or the value you typed in the smoothing option) deviation from the actual geometry.
If you have chatter and wonky movement in small, not linear, moves like a 2mm diameter helix, this can be because there are so many coordinates necessary to describe that helix that GRBL's buffer is just too small to smoothly execute all the lines - the move comes to a halt until the next lines are buffered (your machine executes the commands faster than GRBL can handle this).
So you can help if you reduce the line count of your files by setting a smoothing value in Fusion.
Downside is your accuracy of the part suffers. With 0.1mm smoothing, you won't be able to be accurate to 0.01mm. But i think this anyway out of reach for a shapeoko.
Probably the best would be to say what's the maximum deviation your part can be off and use this value for smoothing.

Auarhau
Posts: 243
Joined: Tue Feb 25, 2014 8:46 pm

Re: Problem with ramps and lead in Fusion.

Post by Auarhau » Wed Feb 10, 2016 8:43 pm

Interesting, thanks. I'll try that too. Loss of accuracy is not really a concern for a helical move, since it's basically just a way to get the bit down into the material before starting to hog it out.
ShapeOko 2. Nema 17 74 oz·in. GAUPS shield on Arduino Uno. DRV8825 Drivers x4 . Kress 1050 FME-1. Z Acme Screw. Threaded inserts table.

Post Reply