Nema 23 pause before start moving

Talk about all things CNC
Post Reply
Ric
Posts: 42
Joined: Wed Apr 29, 2015 2:17 am

Nema 23 pause before start moving

Post by Ric » Mon Nov 30, 2020 12:22 am

I recently upgraded my Shapeoko 2 and replaced the X and Y axis motors with Nema 23. I think things were working well, but I haven't used the machine in a month or two, and when I used it yesterday it was very inaccurate. If I told it to go 10 inches X+, it would do so, but then if I told it to go 10 inches X-, it would only go 9.75. After looking at it a lot, I realized that the motor behaves in a way that I think unusual. Suppose the motor has been moving the carriage left, and I then send a command to go right, any distance. What happens is that after receiving the command, the motor will make noise for .5 to 1 second, and then suddenly move. After this it will move right as normal, without any pause. But then if I send the command to move left, it will again pause a bit, make noise, before moving; after this initial move left, it will move left on command without any pause. I checked all the wiring, and I believe it is tight. I also loosened the belt a bit, but that didn't make any difference. I'm wondering if the motor needs to be replaced, or if something else is likely to be causing this. Any suggestions are appreciated.

trafoos
Posts: 1
Joined: Tue Dec 08, 2020 1:34 pm

Re: Nema 23 pause before start moving

Post by trafoos » Wed Dec 30, 2020 4:25 am

I have written an Arduino Program for a NEMA-23 Stepper Motor, that uses two Push ... -should be able to move between limit switches, when corresponding Push ... Few days before, it was working, when my goal was to press push button only once to start motor from any position and stop at end switch.
https://trafoos.com/wallpapers/whatsapp-wallpaper/

Post Reply