Learn From My 'Mystery Problem'

Talk about all things CNC
Post Reply
Schruminator
Posts: 259
Joined: Wed Oct 30, 2013 1:04 pm
Location: Littleton, CO
Contact:

Learn From My 'Mystery Problem'

Post by Schruminator » Fri Jul 11, 2014 3:41 am

So, I've been using my CNC without any significant issue since Jan/Feb. Until yesterday. I was cutting out a relatively simple design and it'd get halfway into the first pass and just miss steps-- it was roughly at the same place every time, but not quite. My current trim pots are tuned, my steppers and drivers weren't hot to the touch (plus I have 2 fans on the drivers and heat sinks on my steppers)-- I was baffled.

So, I blamed the code (even though the visualizer displayed it correctly). I use Aspire to generate my g-code and I just figured that it was inserting some fancy function in there that my SO2 just wasn't interpreting right. So I just put that job on the back burner for another day.

Anyways, get to tonight-- 30 seconds into a job and the machine was missing steps on the y-axis again. I finally tore apart everything, cleaned contacts, tightened terminal block screws, re-adjusted my trim pots. It was then I found out that no matter how high I adjusted my Y-trim pot, the motor just had no "oomph". Aha! I have found the problem! I traced back the wiring, looking for a nick or a break, I removed all of my electrical tape to check my solder joints. Everything A-OK. Wtf.

So, any guesses on what the issue was?

Set screws. The set screws on my gear/gear shaft were loose. The stepper was spinning his little heart away, but any minor resistance and the gear would slip. After tightening those set screws, I went around and found 3 more that needed tightening (even though they weren't causing problems yet).

TL;DR: Check the bloody set screws. They're tiny but can cause big problems.
1.8m x 1.0m SO2 #3638 / Vectric Aspire / ACME Z-axis / View my photography at http://www.mschrum.com

ronniemcd
Posts: 22
Joined: Sat Jun 28, 2014 2:34 pm
Location: Melbourne, Australia

Re: Learn From My 'Mystery Problem'

Post by ronniemcd » Fri Jul 11, 2014 6:47 am

Where the bloody hell is the like button on these forums? :)

Glad to see you worked it out in the end, and it wasn't anything major. :)

Improbable Construct
Posts: 997
Joined: Tue Apr 10, 2012 3:21 am
Location: Fairhope, AL
Contact:

Re: Learn From My 'Mystery Problem'

Post by Improbable Construct » Fri Jul 11, 2014 12:14 pm

When ever I watch a video from someone looking for help trouble shooting problems like this I usually go by sound.
If it sounds awful = loose wire.
If it sounds normal = loose set screw.
Shapeoko #Classified some of the bolts may be original parts.
Shapeoko 1 # ???? Stainless plates, still in the box.
Shapeoko 2 # 3926 not stock
Shapeoko 3 # 0003
Store:
http://ImprobableConstruct.com
Twitter:
https://twitter.com/ImprblConstruct

WillAdams
Posts: 8629
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Learn From My 'Mystery Problem'

Post by WillAdams » Fri Jul 11, 2014 12:24 pm

An excellent trouble-shooting advice.

Added to the wiki: http://www.shapeoko.com/wiki/index.php/ ... m_Expected

and added (or other mechanical issue such as loose belts).

Okay?
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

stephenjbell
Posts: 25
Joined: Mon Nov 04, 2013 5:16 am

Re: Learn From My 'Mystery Problem'

Post by stephenjbell » Mon Oct 13, 2014 4:06 am

Thank you for this! I've been losing steps on my x-axis for months, and this finally fixed my problem. I had tried adding a fan to my enclosure, messing with the current, upgrading GRBL, and was pretty close to trying the "take it all apart and put it back together" fiasco described.

It'll be great to have a reliable machine again.

Post Reply