Carbide Motion Software Troubleshooting

Talk about all things CNC
semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Carbide Motion Software Troubleshooting

Post by semmons23 » Fri May 08, 2015 9:18 pm

I can see the Shapeoko 3 in Devices but the Carbide Motion software just comes up with a blank screen. Anyone have any ideas on something I can try? Windows 8.1 Enterprise 64 bit. Tried Windows 7 Compatible mode and running as administrator but nothing works. It does the same thing on my other PC but I assumed it was because I don't actually have the Shapepko connected.
Shapeoko 3 - #0073

WillAdams
Posts: 8564
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Carbide Motion Software Troubleshooting

Post by WillAdams » Fri May 08, 2015 9:53 pm

There has already been one person who noted a bum cable — I’ve been wondering if some of my difficulties are caused by that — try a different cable?
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets
Nomad 883 Pro #596 (bamboo)

semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Re: Carbide Motion Software Troubleshooting

Post by semmons23 » Fri May 08, 2015 11:26 pm

I've tried a new cable but no luck. I also hit the 'L' key to bring up the log window and its blank too. Both cables make the motors move when you plug in the wire so I'm thinking its not the wire. I also see the Shapeoko on comm4 in device manager.
Shapeoko 3 - #0073

semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Re: Carbide Motion Software Troubleshooting

Post by semmons23 » Fri May 08, 2015 11:38 pm

I've just tried in on my wife's MacBook and it works perfectly. I have a feeling it doesn't work on this version of Windows (8.1 Enterprise) as both PC's I've tried it on have this version and both come up with a blank screen.
Shapeoko 3 - #0073

semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Re: Carbide Motion Software Troubleshooting

Post by semmons23 » Sun May 10, 2015 2:26 am

Ive also tried a third PC running windows 7 ultimate and it just totally crashes...wtf is up with this software. I have a ticket open with Carbide so I'll update this post if they ever figure it out.
Shapeoko 3 - #0073

semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Re: Carbide Motion Software Troubleshooting

Post by semmons23 » Wed May 13, 2015 7:10 pm

Is anyone else running this software on a 64bit OS? I have just blown away my laptop and installed windows 7 home premium and it doesn't work on that either. The screen just comes up white. I can open the log window but its blank too. This is now 3 PC's and 3 different OS's (all 64bit) and it doesn't work on any of them!
Shapeoko 3 - #0073

WillAdams
Posts: 8564
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Carbide Motion Software Troubleshooting

Post by WillAdams » Wed May 13, 2015 7:38 pm

I've made a page for this on the wiki: http://www.shapeoko.com/wiki/index.php/ ... l_Software

and included my known-to-work configuration (w/ commentary).

and added a note that 64-bit OSs may not work (w/ a link back to your post).

It would be great if everyone who has a working configuration would post the specifics of their setup here (as well as how well it performs) --- or edit the wiki w/ specifics directly.
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets
Nomad 883 Pro #596 (bamboo)

jayftee
Posts: 143
Joined: Tue Apr 14, 2015 3:47 pm
Location: Canada

Re: Carbide Motion Software Troubleshooting

Post by jayftee » Wed May 13, 2015 7:50 pm

WillAdams wrote: and added a note that 64-bit OSs may not work (w/ a link back to your post).
Well, these days, anyone writing a piece of software that doesn't run on x64, or at least run well in x86 within a 64 bit O/S, deserves a swift kick in the rear end.

I mean come on, x64 is not from yesterday. XP has been long dead, unless you pirated it and have been living on a respirator for the last 5 years.

:Sigh
Proud creator of Ike:Core, a 1 cubic foot work area FDM 3D printer based on CoreXY
Shapeoko 3 #00947, Aluminum Bed, Prototype Z Carriage, Porter Cable 450, Min/Max limit switches, Z-Probe, PreciseBits 1/4 & 1/8 Collets, Super-PID v2, IC Dust Shoe

semmons23
Posts: 44
Joined: Wed Feb 18, 2015 8:19 pm

Re: Carbide Motion Software Troubleshooting

Post by semmons23 » Wed May 13, 2015 8:25 pm

Agreed. I have ticket open with Carbide but I've not heard anything. I'm going to load up Win7 Home Premium x86 and see what happens. I tend to think its actually a video driver issue but on 3 PC's with 3 different hardware configs...seems unlikely. Granted none of these are from this decade but that really shouldn't matter. I've run Win7 and 8.1 for years on them with no issues.
Shapeoko 3 - #0073

WillAdams
Posts: 8564
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15
Contact:

Re: Carbide Motion Software Troubleshooting

Post by WillAdams » Wed May 13, 2015 9:03 pm

jayftee wrote:XP has been long dead, unless you pirated it and have been living on a respirator for the last 5 years.
While I agree w/ the sentiment, I’m going to have to take exception to the piracy comment.

I’m still using a Fujitsu Stylistic ST-4121 running Windows XP as my main machine and have been looking for a replacement for a couple of years now, but haven’t been able to find a machine which meets all my needs.
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets
Nomad 883 Pro #596 (bamboo)

Post Reply