Updated to GRBL 0.9, z axis plunges

Talk about all things CNC
Post Reply
overownt
Posts: 5
Joined: Sun Nov 22, 2015 3:40 pm

Updated to GRBL 0.9, z axis plunges

Post by overownt » Mon Nov 23, 2015 1:54 pm

Hello! first off I would like to say it is my first day on the forums, but have had my Shapeoko 2 for quite some time and happy to be a part of the community!

Here is my setup:
Arduino Uno w/ newest revision of Gshield running Grbl 0.09 (current)
Misumi 500x500 T table
Dual Y
1.5 Kw water cooled spindle
Arduino controlled Aluminum cutting fluid drip feed

Here is my issue:
I recently updated my grbl and in addition I updated my Universal Gcode sender and here is what happens. I set the correct baud and connect and set all of my setting to match similar builds. But when I press ANY of the manual directions controls, the Z axis will attempt to plunge as far as possible, after this has occurred, I can control the machine as normal, set the zero and homing position. Disconnect around we go again.

I know my way around it generally but with the update the Grbl commands have been rearranged and I feel I am overlooking something because I cannot find anything that would cause what appears to be some sort of homing cycle.

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Updated to GRBL 0.9, z axis plunges

Post by cvoinescu » Mon Nov 23, 2015 3:01 pm

Try G10 L2 P1 X0 Y0 Z0 to clear any offsets in the G54 (default) work coordinate system. Maybe the EEPROM did not get cleared completely during the upgrade.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

overownt
Posts: 5
Joined: Sun Nov 22, 2015 3:40 pm

Re: Updated to GRBL 0.9, z axis plunges

Post by overownt » Mon Nov 23, 2015 3:45 pm

I will give that a shot as soon as I am home, does that value get held even if the machine is reset?

chamnit
Posts: 376
Joined: Tue Aug 12, 2014 2:16 pm
Location: Albuquerque NM, USA
Contact:

Re: Updated to GRBL 0.9, z axis plunges

Post by chamnit » Mon Nov 23, 2015 4:07 pm

In Grbl v0.9j, there is a new set of wipe EEPROM commands. `$RST=#` will wipe all of the coordinate offsets. While `$RST=*` will restore all of the EEPROM and settings.

cvoinescu
Posts: 4442
Joined: Thu Jul 19, 2012 6:50 pm
Location: Camberley, UK
Contact:

Re: Updated to GRBL 0.9, z axis plunges

Post by cvoinescu » Mon Nov 23, 2015 4:08 pm

chamnit wrote:In Grbl v0.9j, there is a new set of wipe EEPROM commands. `$RST=#` will wipe all of the coordinate offsets. While `$RST=*` will restore all of the EEPROM and settings.
Handy!
overownt wrote:does that value get held even if the machine is reset?
Yes.
Proud owner of ShapeOko #709, eShapeOko #0, and of store.amberspyglass.co.uk

overownt
Posts: 5
Joined: Sun Nov 22, 2015 3:40 pm

Re: Updated to GRBL 0.9, z axis plunges

Post by overownt » Mon Nov 23, 2015 5:42 pm

Interesting! I will give these both a try when I get home, it would be really great to start using it again, I haven't had a good chance to test my drip feed system for cutting fluid

overownt
Posts: 5
Joined: Sun Nov 22, 2015 3:40 pm

Re: Updated to GRBL 0.9, z axis plunges

Post by overownt » Tue Nov 24, 2015 1:12 pm

Terrific! it took awhile but I messed around with both suggestions and now understand how to make it function properly, however as if it were on queue, I now have a huge USB interference issue from my spindle. I can work and operate with it off just fine, but when it is on, it loses connectivity and i hear it connecting and disconnecting repeatedly *windows chime*. I will try relocating the usb and adding some ferrite beads.

Post Reply