GRBL 1.1 : UGS Platform (Error Issues)

Talk about all things CNC
Post Reply
kayaker
Posts: 85
Joined: Fri Feb 13, 2015 2:21 pm
Location: Ottawa, Ontario, Canada

GRBL 1.1 : UGS Platform (Error Issues)

Post by kayaker » Thu Apr 12, 2018 9:45 pm

I have upgraded the following since I last ran a job. I installed the replacement Shapeoko Controller I have have in the drawer for a bit (over a year). I loaded GRBL 1.1 onto the new board and moved to UGS Platform. All of these changes are in preparation for the Shapeoko Touch Probe when they are back on the shelf. I use Fusion 360 for my CAD/CAM.

My Problem. . .

I can navigate around with UGS Platform and everything seems to work fine. However, when I go to run a simple little test job composed of 2 small circles cut into a piece of wood I encounter problems. When I start the job, the Z axis goes straight up until it trips the limit switch and halts the execution of the program. It has erred out with a couple different messages, but the result was the same, it stopped after hitting the limit switch.

I also tried a couple of small jobs I had from before on my original installation (where I used the original controller board, GRBL .08? and and a pre Platform version of UGS along with Fusion 360). Same issue. As soon as you click "go", it moves up the Z axis until it trips the limit switch.

The unit goes through the homing cycle perfectly.

Below are a couple of screen shots of UGS at the point the X-axis hits the limit switch and stops the job. At the bottom of the image screen you can see the console error messages.

Any thoughts that might help me get by this?

Thanks in advance for any guidance.

I also have a second error "M1 T6" which is in the .nc code file for a tool change (which is not applicable here)? Says it doesn't support that command and if I bracket it out, it gets past that error and heads to the Z-axis limit switch error.
Attachments
Z0.6 error.PNG
Z0.6 error.PNG (263.82 KiB) Viewed 860 times
Z5.08 error.PNG
Z5.08 error.PNG (207.72 KiB) Viewed 860 times
Take Care,

Jim. . .
--------------------------------------------------------------------------------------------
In the immortal words of Dr. Johnny Fever; "when everybody is out to get you, paranoid is just good thinking!"

kayaker
Posts: 85
Joined: Fri Feb 13, 2015 2:21 pm
Location: Ottawa, Ontario, Canada

Re: GRBL 1.1 : UGS Platform (Error Issues)

Post by kayaker » Sat Apr 14, 2018 3:14 am

Issue resolved. The process of flashing the new firmware GRBL 1.1 to the Shapeoko controller board resets the G28 location (in my situation at least) to the machine home (X0;Y0:Z0) position. IF your post processor uses the G28 command, its movement to that location engages the limit switches and shuts down the machine. Solution was to find a place in the coordinate system, where you would like the machine to offset to and commit that to the EPROM by issuing the G28.1 instruction (after the machine has been homed). Life is good once again. :)
Take Care,

Jim. . .
--------------------------------------------------------------------------------------------
In the immortal words of Dr. Johnny Fever; "when everybody is out to get you, paranoid is just good thinking!"

Post Reply