S3 stops mid-job

Post Reply
Posts: 38
Joined: Sat Jan 31, 2015 11:05 pm

Re: S3 stops mid-job

Post by sdrevik » Sun Oct 11, 2015 9:41 pm

apspurgeon wrote:I did get one failure after some time, so now I have also soldered an earth/ground on the SO3 board that connects the USB shield to the board. I believe this is what the SO team are also trying in the 'lab'

On mine I have put Alu tape over the top of the control board mount, connected the X,Y,Z metal of the SO3 with wire and grounded, grounded both ends of the USB cable. I used to get a communication failure every 2nd job, now I get none. Of course, making sure all ground/earth points are t the a single point so all at the same earth potential.
Can you post pictures?

Posts: 38
Joined: Sat Jan 31, 2015 11:05 pm

Re: S3 stops mid-job

Post by sdrevik » Sun Oct 11, 2015 9:58 pm

LTEPM wrote:On another forum, users were reporting loss of USB Communication to their machines( not Shapeoko ) when using a thumb drive USB drive.

I've been using a thumb drive and a 2.4GHz logitech keyboard/mouse combo.

Curious if others experiencing the drops are using thumb drives, wireless keyboards/mice or wired keyboards/mice.

I've minimized my drops, but still experience them occasionally.
Laptop, no wireless adapters or thumb drives. Drops out in middle of job, spindle plugged into separate circuit through surge protector. Garage doors don't affect it- it just randomly dies on its own.

Posts: 122
Joined: Mon Jun 08, 2015 9:18 am

Re: S3 stops mid-job

Post by apspurgeon » Sun Oct 11, 2015 11:41 pm

Hi there, this might help? also, I found running of battery only (no AC to laptop) was a lot better than with AC power.

I have had the occasional failure even after these 'mods' but certainly a LOT better.

- Cover the top of the electronics cover with Aluminium tape (shield it)
- Earth the laptop metal case to the same earth as the SO3, this earths the USB cable from laptop side
- Earth the SO3 X, Y and Z

Posts: 38
Joined: Sat Jan 31, 2015 11:05 pm

Re: S3 stops mid-job

Post by sdrevik » Sun Oct 11, 2015 11:56 pm

Thanks, am running the laptop on battery, which seems to be helping. Limits the length of my job, though.

Posts: 9
Joined: Thu Apr 30, 2015 9:27 pm
Location: Germany

Re: S3 stops mid-job

Post by HarryT » Sun Dec 06, 2015 4:13 pm

Hello together, like so many of you I've also had these interruptions.

To stop this I supplied the spindle from another power strip, inserted a lot of ferrites (in the se3 power supply, the spindle AC, the USB cable) and disconneted the laptop from AC. Anything helps a little bit but there were remaining interruptions.

Now I inserted an USB optocoppler based on https://github.com/watterott/USB-Isolat ... or_v10.pdf close to the USB input of S3.
I just use R1-4, C1-4 and IC1. No USB connectors are used, I only cut the cable and dematle the wires. The USB-optocoppler chips costs ~6€ so this solution is quite cheap.

To supply the chip on the S3 side (VBUS2) I have to connect the 5V output signal on the CM Board with VBUS2. There seems to be no direct connection from VBUS input to 5V.

Although I have removed any ferrite, connect the laptop to AC and supply the spindle from the same power strip there are (till now) no further interruptions.
Shapeoko 3 # 610
under construction

Posts: 1
Joined: Sun Mar 15, 2015 10:14 am

Re: S3 stops mid-job

Post by slothink » Fri Dec 11, 2015 10:02 am


First time poster from Oz. Been having the same issues that most of you have. Shapeoko 3 cutting out randomly throughout operation. Generally when I power my spindle up but also at other times.

Just wanted to say thanks to everyone for the suggestions and apspurgeon for his video. So far it has seemed to fix the problem.

Laptop and Shapeoko 3 are plugged into the same power board.
I'm running my spindle and shopvac on a separate circuit to my laptop & Shapeoko 3.
I connected both Y axes and the Spindle housing (Z) back to the housing of the Carbide board with some spare car speaker wire. I figured that the X axis was already earthed to at least the carbide board housing.

Was still having issues so I wired a stereo jack to one end of the car speaker wire and then to the front of one of the Y axes and plugged it into the stereo jack on my laptop next to the usb port that I use for the Shapeoko 3.

Once I had this plugged in, I could power up and down the spindle no worries without causing the Shapeoko 3 to drop out. Ran a two hour job for the first time with no drop-out's.

Early day's I know but it would constantly drop out whenever the spindle powered up so for now I'm optimistic.

Posts: 122
Joined: Mon Jun 08, 2015 9:18 am

Re: S3 stops mid-job

Post by apspurgeon » Mon Dec 21, 2015 9:24 am

Hi Slothink

Good update. I do still get issues but greatly reduced, it's clearly a noise/ground issue through the USB. And I avoid the garage door opener being used!

Keep in contact, good to have another SO3'er in the region

Posts: 50
Joined: Wed Jun 10, 2015 4:00 am
Location: Ohio

Re: S3 stops mid-job

Post by jfdotcom » Tue Dec 29, 2015 7:05 pm

To be honest, the further I visit this forum thread and the hassles I deal with on my machine, I'm really starting to consider this more of a "toy" than the X-carve. Months of having the machine work and then all of a sudden not and then magically does is getting extremely old.
S3 #342 07/2015
My website
YouTube Channel

Posts: 8641
Joined: Mon Apr 09, 2012 6:11 pm
Location: Pennsylvania --- south of the Turnpike, East of US-15

Re: S3 stops mid-job

Post by WillAdams » Tue Dec 29, 2015 7:37 pm

It's my understanding that most people achieve a solution which works for their situation. FWIW, I'd thought you had solved this by putting the router on a separate circuit as suggested on the wiki: http://www.shapeoko.com/forum/viewtopic ... 318#p51318

Given that there are over 1,000 SO3s which have been sold, the forum reports are a small percentage of the machines --- not sure how many more are directly contacting support@carbide3d.com which is what anyone should do if they exhaust the options and suggestions of the forum and wiki.
Shapeoko 3XL #0006 w/ Carbide Compact Router w/0.125″ and ¼″ Carbide 3D precision collets

Posts: 1250
Joined: Mon Apr 09, 2012 5:40 pm
Location: Dixon, IL

Re: S3 stops mid-job

Post by edwardrford » Tue Dec 29, 2015 7:47 pm

Let's mark this as the official answer to this thread:

For *anyone* having a disconnect issue as described in this thread PLEASE contact support (support@carbide3d.com) with a subject line of 'S3 DISCONNECTS'.

From the data we have collected, to date, this problem is effecting a very small percentage of all users. Of course ANY percentage is too many for our liking, and it's a problem we don't want to see at all. The difficult part of 'fixing' the problem is that it's very hard for us to replicate in house - so if you are having a problem, and you can reproduce the problem (someone consistantly) your input will be greatly appreciated!

Again - if your Shapeoko 3 is having this issue (or any issue for that matter) PLEASE contact support and we will, without a doubt get you fixed up one way or another.

We don't want any Shapeoko 3 machines in the wild that people consider to be unreliable - this machine was build and designed to be a workhorse, and should be as reliable as any other tool in your shop. If your machine does not fit that description - we want to make it right, so please contact us!

I've been living and breathing Shapeoko for almost 6 years now - I feel like my name and personal reputation is associated with every single machine that we produce and ship to our customers. If you're not happy with your machine - then we want the chance to fix that.

Shapeoko 1 #0 - a couple of upgrades.
Shapeoko 2 #0 - a couple of upgrades.
Shapeoko 3 #2 - Stock

Post Reply